Moodle
  1. Moodle
  2. MDL-31956

Wrong language component used in the paypal enrolment plugin.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0.7, 2.1, 2.2.1
    • Fix Version/s: 2.1.6, 2.2.3
    • Component/s: Enrolments
    • Labels:
      None
    • Rank:
      38617

      Description

      The file enrol/paypal/ipn.php makes references to two strings, 'enrolmentnew' and 'enrolmentnewuser', in the get_string method it does not pass a component, so 'moodle' is used by default, however these strings are in the 'enrol' language file.

        Activity

        Hide
        Petr Škoda added a comment -

        Thanks for the report.

        Show
        Petr Škoda added a comment - Thanks for the report.
        Hide
        Eloy Lafuente (stronk7) added a comment -

        Integrated, thanks! (21, 22 & master)

        Show
        Eloy Lafuente (stronk7) added a comment - Integrated, thanks! (21, 22 & master)
        Hide
        Eloy Lafuente (stronk7) added a comment -

        Nobody tested this, passing.

        Show
        Eloy Lafuente (stronk7) added a comment - Nobody tested this, passing.
        Hide
        Eloy Lafuente (stronk7) added a comment -

        FCT (fixed, closing, thanks). Ciao

        "I feel a very unusual sensation - if it is not indigestion, I think it must be gratitude!"
        ~ Benjamin Disraeli

        Show
        Eloy Lafuente (stronk7) added a comment - FCT (fixed, closing, thanks). Ciao "I feel a very unusual sensation - if it is not indigestion, I think it must be gratitude!" ~ Benjamin Disraeli

          People

          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: