Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.0.4
    • Fix Version/s: None
    • Component/s: Backup
    • Labels:
      None
    • Affected Branches:
      MOODLE_20_STABLE
    • Rank:
      38713

      Description

      Attempting to backup courses and after the final step (perform backup) it returns with an error as follows

      A required parameter (id) was missing
      Stack trace:

      • line 429 of /lib/setuplib/php: moodle_exception thrown
      • line 464 of /lib/moodlelib.php: call to print_error()
      • line 23 of /backup/backup.php: call to required)param()

      Backups will usually work on small courses where there are only 1 or 2 file/activities/etc on them, but anything that has a normal course load of material (14 weeks, 3 files per week with roughly 5 activities in total) will not backup.

      installed on GoDaddy VDS, have tried increasing max_execution_time to 3600 but that did not have any affect

        Activity

        Michael de Raadt added a comment -

        My initial thought was that this was a timeout issue. It looks like the page is being reloaded after a timeout.

        Is the error occurring after a long time, or is it relatively immediate?

        The number of activities and files in your course does not seem abnormal, but then there could be significantly large files attached to these activities. Also, a large question bank with attachments could be being backed up with the course. In older versions, students private files were also being included in backups. So there are a few things that could be making the backup larger and take longer. There have been a number of recent improvements in backups that could help, if you upgrade.

        Derek Runions added a comment -

        The error does occur after quite a while, as if you were uploading a very large file.

        In these courses there aren't any questions, assignments etc, just documents, and all of them under 8MB.

        All in all, there likely isn't more than 240MB...decently large, but that shouldn't make it break right?

        Michael de Raadt added a comment -

        Hi, Derek.

        On a remove server, I suppose 240MB could time out.

        If it works for a smaller scale but not a larger scale, I would think this is the issue. I don't think this indicates a fault in the codebase.

        Derek Runions added a comment -

        Is there a setting/value that I could change, perhaps on php.ini to make this not happen (in regards to timing out)

        thanks again

        Michael de Raadt added a comment -

        Normally I would recommend increasing the php max_execution_time, but you have done that. Sorry.

        You could try looking in the forums for where others have had this problem previously. I suspect it will have come up there a few times.


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: