Moodle
  1. Moodle
  2. MDL-32090

Groups : 404 not found in "Add/remove users" page

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.1, 2.2, 2.3
    • Fix Version/s: 2.0.9, 2.1.6, 2.2.3
    • Component/s: Groups
    • Labels:
    • Testing Instructions:

      1/ enable edit mode in course
      2/ go to group UI, create group and go to group members
      3/ try to add new block
      4/ expected - page does not redirect to invalid url any more

      Show
      1/ enable edit mode in course 2/ go to group UI, create group and go to group members 3/ try to add new block 4/ expected - page does not redirect to invalid url any more
    • Affected Branches:
      MOODLE_21_STABLE, MOODLE_22_STABLE, MOODLE_23_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE, MOODLE_21_STABLE, MOODLE_22_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      w12_MDL-32090_m23_groupui

      Description

      You get a "404 not found" error when changing language in "Add/remove users" interface of Groups administration in a course.

      Problem is caused by a wrong assignation in $PAGE->set_url :

      $PAGE->set_url('/groups/members.php', array('id'=>$groupid));

      To fix the bug :

      $PAGE->set_url('/group/members.php', array('group'=>$groupid));

        Gliffy Diagrams

          Activity

          Petr Skoda added a comment -

          thanks a lot for the report and proposed patch!

          Sam Hemelryk added a comment -

          Thanks Petr - this has been integrated now

          Adrian Greeve added a comment -

          Tested in branches 2.0 - master. All working as expected.
          Thanks.

          Sam Hemelryk added a comment -

          Congratulations are in order, you've made it, or at least your code has!
          It's now part of Moodle and both the git and cvs repositories have been updated.

          This issue is being marked as fixed and closed.

          Thank you.


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: