Details

    • Type: Sub-task
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.2.2
    • Fix Version/s: 2.3
    • Component/s: General
    • Labels:
    • Testing Instructions:

      1/ enable strict mode in php.ini
      2/ force strict mode in main config.php
      3/ browse around a bit

      there are too many areas affected, detailed code review should be enough I guess

      Show
      1/ enable strict mode in php.ini 2/ force strict mode in main config.php 3/ browse around a bit there are too many areas affected, detailed code review should be enough I guess
    • Affected Branches:
      MOODLE_22_STABLE
    • Fixed Branches:
      MOODLE_23_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      w13_MDL-32095_m23_strict2

      Description

      it is not enough to enable E_STRICT in config.php only

      areas to be fixed:

      • all filters
      • backup/restore (Eloy)
      • all themes
      • repositories

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              skodak Petr Skoda added a comment -

              For Eloy: Strict standards: Declaration of backup_setting::add_dependency() should be compatible with that of base_setting::add_dependency() in /Users/skodak/server/workspace/moodle23/backup/util/settings/backup_setting.class.php on line 32

              nebgor Aparup Banerjee added a comment -

              theme renderers: Strict Standards: Declaration of theme_anomaly_core_renderer::block() should be compatible with that of core_renderer::block() in /home/aparup/mcode/integration/theme/anomaly/renderers.php on line 84

              rajeshtaneja Rajesh Taneja added a comment -

              Adding E_ALL | E_STRICT, show
              Defined in config.php
              Invalid current value: 32767
              message on Debugging page (Settings -> Site administration -> Development -> Debugging)
              FYI: Attaching screen shot

              rajeshtaneja Rajesh Taneja added a comment -

              Some more messages:

              1. Strict standards: Accessing static property filter_activitynames::$activitylist as non static in /usr/local/www/moodleintegration/filter/activitynames/filter.php on line 47
              2. Strict standards: Accessing static property filter_activitynames::$cachedcourseid as non static in /usr/local/www/moodleintegration/filter/activitynames/filter.php on line 46
              skodak Petr Skoda added a comment -

              The invalid value not a problem, thanks for the links notices, I did not fix filters yet (because I forgot).

              skodak Petr Skoda added a comment -

              there will be most probably "part 3", please add info here for now

              skodak Petr Skoda added a comment -

              todo:
              Strict standards: Creating default object from empty value in /Users/skodak/server/workspace/moodle23/admin/index.php on line 203

              skodak Petr Skoda added a comment -

              two more commits added - one for admin/index.php and testoutputlib.php, thanks Eloy!

              stronk7 Eloy Lafuente (stronk7) added a comment -

              Adding comment here about the need to consider upgrading to simpletest 1.1.0, that should be E_STRICT compliant, so we can run both the web-ui and the ci tests without having to hack CFG->debug to exclude E_STRICT.

              Surely another issue will be perfect to achieve it, I bet we'll need some re-hack apart from raw upgrade.

              Ciao

              stronk7 Eloy Lafuente (stronk7) added a comment -

              Integrated, thanks!

              stronk7 Eloy Lafuente (stronk7) added a comment -

              For reference, MDL-32250 has been created about to update to newer (e_strict compliant) simpletest.

              stronk7 Eloy Lafuente (stronk7) added a comment -

              I've played a bit with the changes applied here (@ backup, enrol, some repos) plus have installed/upgraded and run all the simple tests. No regression was found.

              So... passing, thanks!

              stronk7 Eloy Lafuente (stronk7) added a comment -

              And this has landed upstream, finally! Yay!

              תודה רבה && شكرا جزيلا



              Closing, ciao


                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  1 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    25/Jun/12