Moodle
  1. Moodle
  2. MDL-32125

Auto subscription mode change not reflecting subscribers

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0.7, 2.2.1, 2.2.7, 2.3.4, 2.4.1
    • Fix Version/s: 2.3.5, 2.4.2
    • Component/s: Forum
    • Testing Instructions:
      Hide
      1. Create a forum with Optional subscription
      2. Check the subscribers (should be none)
      3. In "Forum administration", click on "Edit settings"
      4. Change the subscription mode to "Auto subscription", then click on "Save and display"
      5. Check the subscribers (should be all there)
      6. Turn editing on
      7. Remove all members manually
      8. In "Forum administration", click on "Edit settings"
      9. Change the subscription mode to "Optional subscription", then click on "Save and display"
      10. In "Forum administration". change the subscription mode to "Auto subscription" - a message is displayed "Everyone is now subscribed to this forum"
      11. Check the subscribers (should be all there)
      12. Enrol a student in the course
      13. Check the subscribers (Should be all there, including the new enrolled student)
      Show
      Create a forum with Optional subscription Check the subscribers (should be none) In "Forum administration", click on "Edit settings" Change the subscription mode to "Auto subscription", then click on "Save and display" Check the subscribers (should be all there) Turn editing on Remove all members manually In "Forum administration", click on "Edit settings" Change the subscription mode to "Optional subscription", then click on "Save and display" In "Forum administration". change the subscription mode to "Auto subscription" - a message is displayed "Everyone is now subscribed to this forum" Check the subscribers (should be all there) Enrol a student in the course Check the subscribers (Should be all there, including the new enrolled student)
    • Workaround:
      Hide

      Ensure you create the forum with 'Auto subscription' mode as all students are added as subscribers if this is selected when the forum is created.

      Show
      Ensure you create the forum with 'Auto subscription' mode as all students are added as subscribers if this is selected when the forum is created.
    • Affected Branches:
      MOODLE_20_STABLE, MOODLE_22_STABLE, MOODLE_23_STABLE, MOODLE_24_STABLE
    • Fixed Branches:
      MOODLE_23_STABLE, MOODLE_24_STABLE
    • Pull from Repository:
    • Pull 2.4 Branch:
      MDL-32125-moodle24
    • Pull Master Branch:
      MDL-32125-master
    • Rank:
      38845

      Description

      Forum subscribers are not updated when a forum with 'Optional subscription' mode is changed to 'Auto subscription'. The Subscribers do not appear to be updated on a forum update but are subscribed on a forum add.
      Refer forum post http://moodle.org/mod/forum/discuss.php?d=198257#p866755

        Issue Links

          Activity

          Hide
          Teresa Gibbison added a comment -

          Just another comment that I tested this in our site as well as my development site and demo.moodle.net [2.2.1]

          Show
          Teresa Gibbison added a comment - Just another comment that I tested this in our site as well as my development site and demo.moodle.net [2.2.1]
          Hide
          Teresa Gibbison added a comment -

          Another test shows that importing a forum with 'Auto subscription' doesn't automatically subscribe the current users either. The method to subscribe everyone occurs when the forum is created (via forum_add_instance) but I can't see where it is called when updating a forum OR importing one.

          Show
          Teresa Gibbison added a comment - Another test shows that importing a forum with 'Auto subscription' doesn't automatically subscribe the current users either. The method to subscribe everyone occurs when the forum is created (via forum_add_instance) but I can't see where it is called when updating a forum OR importing one.
          Hide
          Helen Foster added a comment -

          Teresa, thanks for your report, with testing instructions and workaround, and for checking whether the bug exists on other sites - very helpful

          Show
          Helen Foster added a comment - Teresa, thanks for your report, with testing instructions and workaround, and for checking whether the bug exists on other sites - very helpful
          Hide
          Kanika Goyal added a comment - - edited

          Hi Teresa and Helen,
          I found out the same.
          Here is the patch-
          for MOODLE_22_STABLE -
          https://github.com/kanikagoyal/moodle/compare/MOODLE_22_STABLE...m22_MDL-32125_forum_subscription_change_reflected

          for master -
          https://github.com/kanikagoyal/moodle/compare/master...master_MDL-32125_forum_subscription_change_reflected

          Please do let me know if any changes are required.

          Show
          Kanika Goyal added a comment - - edited Hi Teresa and Helen, I found out the same. Here is the patch- for MOODLE_22_STABLE - https://github.com/kanikagoyal/moodle/compare/MOODLE_22_STABLE...m22_MDL-32125_forum_subscription_change_reflected for master - https://github.com/kanikagoyal/moodle/compare/master...master_MDL-32125_forum_subscription_change_reflected Please do let me know if any changes are required.
          Hide
          Teresa Gibbison added a comment -

          Thanks Kanika for this. We'll be able to add this to our code now
          Teresa

          Show
          Teresa Gibbison added a comment - Thanks Kanika for this. We'll be able to add this to our code now Teresa
          Hide
          Kanika Goyal added a comment -

          You are welcome Teresa.
          Hope it worked great for you
          Thanks!

          Show
          Kanika Goyal added a comment - You are welcome Teresa. Hope it worked great for you Thanks!
          Hide
          Dan Marsden added a comment -

          looks good to me (haven't tested it though) - pushing for peer review.

          Show
          Dan Marsden added a comment - looks good to me (haven't tested it though) - pushing for peer review.
          Hide
          Sam Hemelryk added a comment -

          Thanks Kanika,

          The changes look good thanks and appear to work well.
          I'll put this up for integration now as by all means it is there, however a couple of things to note/ask.

          1. Do you know whether this issue effects Moodle 2.1+ (we are maintaining 2.1+ and 2.2+ while developing master soon to be 2.3)

          2. In the future it would be great if you could structure your commit messages as below:

          MDL-32125 mod_forum: updating subscription mode not reflected
          

          Many thanks
          Sam

          Show
          Sam Hemelryk added a comment - Thanks Kanika, The changes look good thanks and appear to work well. I'll put this up for integration now as by all means it is there, however a couple of things to note/ask. 1. Do you know whether this issue effects Moodle 2.1+ (we are maintaining 2.1+ and 2.2+ while developing master soon to be 2.3) 2. In the future it would be great if you could structure your commit messages as below: MDL-32125 mod_forum: updating subscription mode not reflected Many thanks Sam
          Hide
          Eloy Lafuente (stronk7) added a comment -

          The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

          TIA and ciao

          Show
          Eloy Lafuente (stronk7) added a comment - The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week. TIA and ciao
          Hide
          Sam Hemelryk added a comment -

          Sorry Apu stealing this off your queue

          Show
          Sam Hemelryk added a comment - Sorry Apu stealing this off your queue
          Hide
          Sam Hemelryk added a comment -

          Hi guys,

          Petr was just having a chat to me and raised this issue.
          He noted that with the patched code if the mode is FORUM_INITIALSUBSCRIBE then all users will be subscribed even if the mode wasn't actually changed (mode=FORUM_INITIALSUBSCRIBE to start with). This would ubdoutbedly annoy a few people who would be resubscribed every time someone edited the forum.
          A check needs to be added to ensure that we only subscribe users if the mode was changed to FORUM_INITIALSUBSCRIBE from sonething else.

          Cheers
          Sam

          Show
          Sam Hemelryk added a comment - Hi guys, Petr was just having a chat to me and raised this issue. He noted that with the patched code if the mode is FORUM_INITIALSUBSCRIBE then all users will be subscribed even if the mode wasn't actually changed (mode=FORUM_INITIALSUBSCRIBE to start with). This would ubdoutbedly annoy a few people who would be resubscribed every time someone edited the forum. A check needs to be added to ensure that we only subscribe users if the mode was changed to FORUM_INITIALSUBSCRIBE from sonething else. Cheers Sam
          Hide
          Kanika Goyal added a comment -

          Hi Sam,

          Thanks for pointing this out. I have added the required check. Please have a look at it - https://github.com/kanikagoyal/moodle/compare/master...master_MDL-32125_forum_subscription_change_reflected
          I have updated the other branch as well.

          I also found the similar issue in Moodle 2.1+, the patch for the branch MOODLE_21_STABLE - https://github.com/kanikagoyal/moodle/compare/MOODLE_21_STABLE...m21_MDL-32125_forum_subscription_change_reflected

          Also I have edited the commit message as per your suggestion

          Thanks,
          Kanika

          Show
          Kanika Goyal added a comment - Hi Sam, Thanks for pointing this out. I have added the required check. Please have a look at it - https://github.com/kanikagoyal/moodle/compare/master...master_MDL-32125_forum_subscription_change_reflected I have updated the other branch as well. I also found the similar issue in Moodle 2.1+, the patch for the branch MOODLE_21_STABLE - https://github.com/kanikagoyal/moodle/compare/MOODLE_21_STABLE...m21_MDL-32125_forum_subscription_change_reflected Also I have edited the commit message as per your suggestion Thanks, Kanika
          Hide
          Teresa Gibbison added a comment -

          Thanks heaps for your efforts everyone

          This looks to add subscribers on a forum update - there is also the ability to change the subscription mode from the Settings menu 'Settings - Forum administration - Subscription mode' which uses the code in subscribe.php

          There seems to be some other checks missing for these subscription options. I initially tested this with just the 'Optional' mode as our issue but more testing shows other inconsistencies. When you change a forum which has subscribers to 'Subscription disabled' those who were subscribed are still subscribed... I would disable subscription to prevent anyone subscribed from being subscribed so would expect everyone to be unsubscribed?

          Also if I change a forum which has either forced or auto (where everyone is subscribed) to Optional then everyone is still subscribed - which is the opposite of what happens when the forum is created (where nobody is subscribed and need to opt in)

          Sorry to give you more to think about!
          Cheers
          Teresa

          Show
          Teresa Gibbison added a comment - Thanks heaps for your efforts everyone This looks to add subscribers on a forum update - there is also the ability to change the subscription mode from the Settings menu 'Settings - Forum administration - Subscription mode' which uses the code in subscribe.php There seems to be some other checks missing for these subscription options. I initially tested this with just the 'Optional' mode as our issue but more testing shows other inconsistencies. When you change a forum which has subscribers to 'Subscription disabled' those who were subscribed are still subscribed... I would disable subscription to prevent anyone subscribed from being subscribed so would expect everyone to be unsubscribed? Also if I change a forum which has either forced or auto (where everyone is subscribed) to Optional then everyone is still subscribed - which is the opposite of what happens when the forum is created (where nobody is subscribed and need to opt in) Sorry to give you more to think about! Cheers Teresa
          Hide
          Carl Hodkinson added a comment -

          As the latest comments for this are from April, I am just reporting that this is occurring on a Moodle 2.1.7+ (Build: 20120719) client site in that if an existing forum's subscription is change to Auto subscription, all students are unsubscribed even though the message contradicts this.

          What is happening with this so that our client can be informed?

          Show
          Carl Hodkinson added a comment - As the latest comments for this are from April, I am just reporting that this is occurring on a Moodle 2.1.7+ (Build: 20120719) client site in that if an existing forum's subscription is change to Auto subscription, all students are unsubscribed even though the message contradicts this. What is happening with this so that our client can be informed?
          Hide
          Dan Marsden added a comment -

          I was only looking at this as part of the GSOC application process (Kanika was accepted as a GSOC student) - re-assigning this back to moodle.com for any further work required. - thanks!

          Show
          Dan Marsden added a comment - I was only looking at this as part of the GSOC application process (Kanika was accepted as a GSOC student) - re-assigning this back to moodle.com for any further work required. - thanks!
          Hide
          Klaus Steitz added a comment -

          On Moodle 2.3.1 (Build: 20120706) the Problem is still occuring that changing from Optional subscription to Auto subscription takes no effect at the subscribers. Differing from above described effects our test-results are that it just has no effect, but manually subscribed users keep subscribed. Changing from forced to Auto has the effect that only the manually subscribed users keep subscribed.

          Show
          Klaus Steitz added a comment - On Moodle 2.3.1 (Build: 20120706) the Problem is still occuring that changing from Optional subscription to Auto subscription takes no effect at the subscribers. Differing from above described effects our test-results are that it just has no effect, but manually subscribed users keep subscribed. Changing from forced to Auto has the effect that only the manually subscribed users keep subscribed.
          Hide
          Aparup Banerjee added a comment -

          Hm, i can't remember this (oh stolen heh) but there seems to be a patch here waiting for a peer-review.
          putting this up for peer-review now with the most recent patch from Kanika.
          Please reopen if more development is needed (it will probably wait in stable backlog if its reopened).

          Show
          Aparup Banerjee added a comment - Hm, i can't remember this (oh stolen heh) but there seems to be a patch here waiting for a peer-review. putting this up for peer-review now with the most recent patch from Kanika. Please reopen if more development is needed (it will probably wait in stable backlog if its reopened).
          Hide
          Sam Hemelryk added a comment -

          Looks good to me. I've put this up for integration now as the assignee is moodle.com.

          Just noting that I am always very dubious about changes like this as it can affect the choices other users have already made. However I definitely see the good in this, and I would say it is the expected behaviour.

          Cheers
          Sam

          Show
          Sam Hemelryk added a comment - Looks good to me. I've put this up for integration now as the assignee is moodle.com. Just noting that I am always very dubious about changes like this as it can affect the choices other users have already made. However I definitely see the good in this, and I would say it is the expected behaviour. Cheers Sam
          Hide
          Eloy Lafuente (stronk7) added a comment -

          The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

          TIA and ciao

          Show
          Eloy Lafuente (stronk7) added a comment - The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week. TIA and ciao
          Hide
          Eloy Lafuente (stronk7) added a comment -

          The integration of this issue has been delayed to next week because the integration period is over (Monday, Tuesday) and testing must happen on Wednesday.

          This change to a more rigid timeframe on each integration/testing cycle aims to produce a better and clear separation and organization of tasks for everybody.

          This is a bulk-automated message, so if you want to blame somebody/thing/where, don't do it here (use git instead) :-D :-P

          Apologizes for the inconvenient, this will be integrated next week. Thanks for your collaboration & ciao

          Show
          Eloy Lafuente (stronk7) added a comment - The integration of this issue has been delayed to next week because the integration period is over (Monday, Tuesday) and testing must happen on Wednesday. This change to a more rigid timeframe on each integration/testing cycle aims to produce a better and clear separation and organization of tasks for everybody. This is a bulk-automated message, so if you want to blame somebody/thing/where, don't do it here (use git instead) :-D :-P Apologizes for the inconvenient, this will be integrated next week. Thanks for your collaboration & ciao
          Hide
          Sam Hemelryk added a comment -

          Thanks guys, this has been integrated now

          Show
          Sam Hemelryk added a comment - Thanks guys, this has been integrated now
          Hide
          Adrian Greeve added a comment -

          I tried this in 2.2 and master.
          When I changed the subscription to 'Auto subscription' nobody was subscribed to the forum.
          I did a quick check in subscribe.php and I couldn't find a reference to forum_update_instance() which is where the patch is contained. I then did a grep for that function and couldn't find a reference to it at all.

          Show
          Adrian Greeve added a comment - I tried this in 2.2 and master. When I changed the subscription to 'Auto subscription' nobody was subscribed to the forum. I did a quick check in subscribe.php and I couldn't find a reference to forum_update_instance() which is where the patch is contained. I then did a grep for that function and couldn't find a reference to it at all.
          Hide
          Aparup Banerjee added a comment - - edited

          hm, there's no assignee here atm . this is a candidate for reverting.
          Adrian: this seem to be for 2.2.x and 2.3.x only (not master from the fix versions)

          Show
          Aparup Banerjee added a comment - - edited hm, there's no assignee here atm . this is a candidate for reverting. Adrian: this seem to be for 2.2.x and 2.3.x only (not master from the fix versions)
          Hide
          Eloy Lafuente (stronk7) added a comment -

          This issue has been reverted (22, 23 and master), reopening...

          Ciao

          Show
          Eloy Lafuente (stronk7) added a comment - This issue has been reverted (22, 23 and master), reopening... Ciao
          Hide
          CiBoT added a comment -

          Moving this reopened issue out from current integration. Please, re-submit it for integration once ready.

          Show
          CiBoT added a comment - Moving this reopened issue out from current integration. Please, re-submit it for integration once ready.
          Hide
          Michael de Raadt added a comment -

          To keep the ball rolling on this issue, I've changed a few roles around.

          Sam, I've set you as assignee as you seem most familiar with the code. I've made Adrian Peer reviewer as he has had a look.

          Kanika, you are welcome to continue begin involved in this issue. If you can put forward a new patch, that would save us a lot of work.

          Show
          Michael de Raadt added a comment - To keep the ball rolling on this issue, I've changed a few roles around. Sam, I've set you as assignee as you seem most familiar with the code. I've made Adrian Peer reviewer as he has had a look. Kanika, you are welcome to continue begin involved in this issue. If you can put forward a new patch, that would save us a lot of work.
          Hide
          James Cracknell added a comment -

          The change that went through on the 13th stopped my Moodle implementation from working with sending out emails to subscribers...

          Show
          James Cracknell added a comment - The change that went through on the 13th stopped my Moodle implementation from working with sending out emails to subscribers...
          Hide
          James Cracknell added a comment -

          In addition I've found I also can not edit subscribers manually now... v2.3.2+ (latest)

          Show
          James Cracknell added a comment - In addition I've found I also can not edit subscribers manually now... v2.3.2+ (latest)
          Hide
          Paul Masson added a comment -

          My instance 2.3.2 there seems to be the same or similar problem when changing from 'Optional' to 'Forced'.
          When I make the change, it says 'all users subscribed' but when I 'Show/Edit Subscribers' the list is blank, and searching will not list any students.
          However, when I 'Check Permissions' in the forum, and randomly select a student, they have subscription permissions.

          Show
          Paul Masson added a comment - My instance 2.3.2 there seems to be the same or similar problem when changing from 'Optional' to 'Forced'. When I make the change, it says 'all users subscribed' but when I 'Show/Edit Subscribers' the list is blank, and searching will not list any students. However, when I 'Check Permissions' in the forum, and randomly select a student, they have subscription permissions.
          Hide
          Annick Fructoso added a comment -

          Using Moodle 2.3.1, trying to change the News Forum to auto suscription has the effect to remove everybody from the forum....

          Show
          Annick Fructoso added a comment - Using Moodle 2.3.1, trying to change the News Forum to auto suscription has the effect to remove everybody from the forum....
          Hide
          Gilles-Philippe Leblanc added a comment -

          Did someone continue working on this one ? I may continue from here if wanted.

          Show
          Gilles-Philippe Leblanc added a comment - Did someone continue working on this one ? I may continue from here if wanted.
          Hide
          Gilles-Philippe Leblanc added a comment -

          Here is the solution a little improved.

          The problem do not just affect 2.2 and 2.3 but all the branches, including master.

          @Adrian: You will not find a reference to forum_update_instance() directly because the method is called like that in:

          course/modedit.php
          $updateinstancefunction = $fromform->modulename."_update_instance";
          

          @To all: Its important to understand that the "force subscribe" method do not actually manually subscribe the users. It only consider all user of the course as subscribed but no one is inserted in the subscribe list. So, when you switch from force subscribe mode to another one, it seams that a unsubscribe occurs but its not. It only return to its original manually subcribed users.

          Maybe we should subscribe manually all users when we select the force subscribe mode so when we switch to another mode, the users will all remain subscribed. I propose to create a task about it if this behavior is desired.

          So, if we exclude the previous case, the solution proposed by Kanika to specifically fix the auto mode seems to be correct, we only forgot to add this solution to "Subscription mode" in "Forum administration" on the "Settings" block.

          Finally, when this task will be close, don't forget to remove the warning in the forum settings documentation:
          http://docs.moodle.org/24/en/Forum_settings#Subscription_mode

          Show
          Gilles-Philippe Leblanc added a comment - Here is the solution a little improved. The problem do not just affect 2.2 and 2.3 but all the branches, including master. @Adrian: You will not find a reference to forum_update_instance() directly because the method is called like that in: course/modedit.php $updateinstancefunction = $fromform->modulename. "_update_instance" ; @To all: Its important to understand that the "force subscribe" method do not actually manually subscribe the users. It only consider all user of the course as subscribed but no one is inserted in the subscribe list. So, when you switch from force subscribe mode to another one, it seams that a unsubscribe occurs but its not. It only return to its original manually subcribed users. Maybe we should subscribe manually all users when we select the force subscribe mode so when we switch to another mode, the users will all remain subscribed. I propose to create a task about it if this behavior is desired. So, if we exclude the previous case, the solution proposed by Kanika to specifically fix the auto mode seems to be correct, we only forgot to add this solution to "Subscription mode" in "Forum administration" on the "Settings" block. Finally, when this task will be close, don't forget to remove the warning in the forum settings documentation: http://docs.moodle.org/24/en/Forum_settings#Subscription_mode
          Hide
          Gilles-Philippe Leblanc added a comment -

          Here is the previous branches from Kanika Goyal:
          Pull 2.2 Branch:
          m22_MDL-32125_forum_subscription_change_reflected
          Pull 2.2 Diff URL:
          https://github.com/kanikagoyal/moodle/compare/MOODLE_22_STABLE...m22_MDL-32125_forum_subscription_change_reflected
          Pull Master Branch:
          master_MDL-32125_forum_subscription_change_reflected
          Pull Master Diff URL:
          https://github.com/kanikagoyal/moodle/compare/master...master_MDL-32125_forum_subscription_change_reflected

          Show
          Gilles-Philippe Leblanc added a comment - Here is the previous branches from Kanika Goyal: Pull 2.2 Branch: m22_ MDL-32125 _forum_subscription_change_reflected Pull 2.2 Diff URL: https://github.com/kanikagoyal/moodle/compare/MOODLE_22_STABLE...m22_MDL-32125_forum_subscription_change_reflected Pull Master Branch: master_ MDL-32125 _forum_subscription_change_reflected Pull Master Diff URL: https://github.com/kanikagoyal/moodle/compare/master...master_MDL-32125_forum_subscription_change_reflected
          Hide
          Adrian Greeve added a comment -

          Hello Gilles-Philippe,

          I've had a look at your patch and the original patch from Kanika.

          I personally don't think that we need to subscribe all of the users when force subscribing, but really it's a personal preference as to which way it is done.
          Either patch would be fine to integrate.

          Thanks.

          Show
          Adrian Greeve added a comment - Hello Gilles-Philippe, I've had a look at your patch and the original patch from Kanika. I personally don't think that we need to subscribe all of the users when force subscribing, but really it's a personal preference as to which way it is done. Either patch would be fine to integrate. Thanks.
          Hide
          Gilles-Philippe Leblanc added a comment - - edited

          Hello Adrian,

          So if I understand well, you propose to add the ability of subscribe all of the users when force subscribing directly in this task and that why you re-put this task in "development in progress" mode.

          As you said, you don't personally think that we need to do that. I'm sure your not alone to think in this way. My team and I are not sure about this too.

          So I propose to leave the patch as is and address the problem in the task MDL-38224.

          Show
          Gilles-Philippe Leblanc added a comment - - edited Hello Adrian, So if I understand well, you propose to add the ability of subscribe all of the users when force subscribing directly in this task and that why you re-put this task in "development in progress" mode. As you said, you don't personally think that we need to do that. I'm sure your not alone to think in this way. My team and I are not sure about this too. So I propose to leave the patch as is and address the problem in the task MDL-38224 .
          Hide
          Eloy Lafuente (stronk7) added a comment -

          The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

          TIA and ciao

          Show
          Eloy Lafuente (stronk7) added a comment - The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week. TIA and ciao
          Hide
          Gilles-Philippe Leblanc added a comment -

          The branches has been rebased.
          TIA and ciao

          Show
          Gilles-Philippe Leblanc added a comment - The branches has been rebased. TIA and ciao
          Hide
          Sam Hemelryk added a comment -

          Alrighty - this has been integrated once more.
          After reading through our docs and any associated commentary I could find I do think this change is in the right direction and I've integrated it.

          Hopefully all goes well this time.

          Show
          Sam Hemelryk added a comment - Alrighty - this has been integrated once more. After reading through our docs and any associated commentary I could find I do think this change is in the right direction and I've integrated it. Hopefully all goes well this time.
          Hide
          Frédéric Massart added a comment -

          Passing, thanks!

          Show
          Frédéric Massart added a comment - Passing, thanks!
          Hide
          Eloy Lafuente (stronk7) added a comment -

          This is valid for unlimited entries to the, soon to be unveiled, Moodle Codebase Gardens. It includes free access to all facilities.

          Personal and non-transferable to all assignees, reviewers and testers in this issue. Valid until switching to Blackboard (100000€ penalization will be applied).

          Thanks, closing as fixed!

          Show
          Eloy Lafuente (stronk7) added a comment - This is valid for unlimited entries to the, soon to be unveiled, Moodle Codebase Gardens. It includes free access to all facilities. Personal and non-transferable to all assignees, reviewers and testers in this issue. Valid until switching to Blackboard (100000€ penalization will be applied). Thanks, closing as fixed!

            People

            • Votes:
              11 Vote for this issue
              Watchers:
              22 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: