Moodle
  1. Moodle
  2. MDL-32134

image/png missing language string

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.2
    • Fix Version/s: 2.1.6, 2.2.3
    • Component/s: Language
    • Labels:
    • Testing Instructions:
      1. Go to [Site administration->Plugins->Repositories->Manage repositories] and make Youtube videos and Wikimedia 'Enabled and visible'.
      2. Create an activity which uses a text editor. (I chose a lesson, but it could be a reply in a forum)
      3. Click the moodle media button on the text editor and click 'Find or upload a sound, video or applet...'
      4. Select Wikimedia and then do a search for test
      5. Select one of the results which is a PNG file
      Show
      Go to [Site administration->Plugins->Repositories->Manage repositories] and make Youtube videos and Wikimedia 'Enabled and visible'. Create an activity which uses a text editor. (I chose a lesson, but it could be a reply in a forum) Click the moodle media button on the text editor and click 'Find or upload a sound, video or applet...' Select Wikimedia and then do a search for test Select one of the results which is a PNG file
    • Affected Branches:
      MOODLE_22_STABLE
    • Fixed Branches:
      MOODLE_21_STABLE, MOODLE_22_STABLE
    • Pull Master Branch:
    • Rank:
      38856

      Description

      As Jason discovered:

      Invalid get_string() identifier: 'image/png' or component 'mimetypes'
      
      line 5962 of /lib/moodlelib.php: call to debugging()
      line 6552 of /lib/moodlelib.php: call to core_string_manager->get_string()
      line 177 of /repository/repository_ajax.php: call to get_string(){"error":"[[image\/png]] filetype cannot be accepted.","stacktrace":"* 
      line 177 of \/repository\/repository_ajax.php: moodle_exception thrown\n","debuginfo":null,"reproductionlink":"http:\/\/localhost\/istable21\/"
      

        Issue Links

          Activity

          Michael de Raadt added a comment -

          It would be good to get some replication steps for this.

          Dan Poltawski added a comment -

          Putting this up for integration.

          I'm not sure I like this mimetype language file - its clearly pretty incomplete for english, must be even worse for other languages.

          Dan Poltawski added a comment -

          The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

          TIA and ciao

          Eloy Lafuente (stronk7) added a comment -

          Integrated, thanks!

          Ankit Agarwal added a comment -

          After step 5 in the testing instruction I get the following error
          "PNG image filetype cannot be accepted."

          Looks like expected result to me.
          Passing
          Thanks

          Eloy Lafuente (stronk7) added a comment -

          This has been near becoming rejected, because it's not the best code you are able to produce.

          But, luckily, at the end, it has landed and has been spread to all repos out there.

          Many thanks and, don't forget it, keep improving your skills, you can!

          Closing, ciao

          Naveen added a comment -

          I`m getting this error while uploading a file to course

          {"error":"File filetype cannot be accepted.","stacktrace":null,"debuginfo":null,"reproductionlink":null}

          Plz help me How to upload a file into course ?


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: