Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-32158

Fix course restricted module restore from 1.9 to 2.x

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: 1.9.17, 2.2.2
    • Fix Version/s: STABLE backlog
    • Component/s: Backup
    • Labels:
    • Affected Branches:
      MOODLE_19_STABLE, MOODLE_22_STABLE

      Description

      Found this error while testing MDL-19125.

      Unable to restoring to 2.x from 1.9 course backup file with the following setting:

      Enabling module security and preventing teachers from adding the disallowed modules.

      To reproduce:
      1. Using a Moodle 1.9 site, turn on the Module security feature, and set it to restrict modules for all courses, with a default list.

      2. Go into a course in this site, go to the course settings, make sure module security is turned on there, and that the list of allowed modules is right, then Save the form.

      3. Backup this course, and restore it into your Moodle 2.3 dev install. Verify that role overrides are created to prevent Teachers from adding the disallowed modules.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned
              Reporter:
              rwijaya Rossiani Wijaya
              Participants:
              Component watchers:
              Adrian Greeve, Jake Dallimore, Mathew May, Mihail Geshoski, Peter Dias
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated: