Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-32166

"Missing" language strings for finalgrade and finalgrade_help

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Duplicate
    • Affects Version/s: 2.2.2
    • Fix Version/s: None
    • Component/s: Gradebook, Language
    • Labels:
    • Affected Branches:
      MOODLE_22_STABLE

      Description

      When grading an item that uses a scale the following messages show up:

      Help title string does not exist: [finalgrade, finalgrade]
      line 432 of \lib\outputcomponents.php: call to debugging()
      line 1642 of \lib\outputrenderers.php: call to help_icon->diag_strings()
      line 1586 of \lib\formslib.php: call to core_renderer->help_icon()
      line 86 of \grade\edit\tree\grade_form.php: call to MoodleQuickForm->addHelpButton()
      line 154 of \lib\formslib.php: call to edit_grade_form->definition()
      line 98 of z:\SVN\moodle\branches\moodle_2_2\moodle\grade\edit\tree\grade.php: call to moodleform->moodleform()

      Help contents string does not exist: [finalgrade_help, finalgrade]
      line 435 of \lib\outputcomponents.php: call to debugging()
      line 1642 of \lib\outputrenderers.php: call to help_icon->diag_strings()
      line 1586 of \lib\formslib.php: call to core_renderer->help_icon()
      line 86 of \grade\edit\tree\grade_form.php: call to MoodleQuickForm->addHelpButton()
      line 154 of \lib\formslib.php: call to edit_grade_form->definition()
      line 98 of z:\SVN\moodle\branches\moodle_2_2\moodle\grade\edit\tree\grade.php: call to moodleform->moodleform()

      Invalid get_string() identifier: 'finalgrade' or component 'finalgrade'. Perhaps you are missing $string['finalgrade'] = ''; in mod/finalgrade/lang/en/finalgrade.php?
      line 6314 of \lib\moodlelib.php: call to debugging()
      line 6906 of \lib\moodlelib.php: call to core_string_manager->get_string()
      line 1662 of \lib\outputrenderers.php: call to get_string()
      line 70 of \lib\outputrenderers.php: call to core_renderer->render_help_icon()
      line 1648 of \lib\outputrenderers.php: call to renderer_base->render()
      line 1586 of \lib\formslib.php: call to core_renderer->help_icon()
      line 86 of \grade\edit\tree\grade_form.php: call to MoodleQuickForm->addHelpButton()
      line 154 of \lib\formslib.php: call to edit_grade_form->definition()
      line 98 of z:\SVN\moodle\branches\moodle_2_2\moodle\grade\edit\tree\grade.php: call to moodleform->moodleform()

      Caused by line 83 in grade/edit/tree/grade_form.php

      See: https://github.com/steelej/moodle/commit/b0a37aad49ca4eb4dadd5ff81de3afc056467443 for fix.

        Gliffy Diagrams

          Issue Links

            Activity

            salvetore Michael de Raadt added a comment -

            Thanks again.

            ankit_frenz Ankit Agarwal added a comment -

            This issue has been fixed by MDL-26523

            closing this. Please feel free to create a new issue, if you are still facing this.


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: