Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-32293

Consider moving the upgrade_set_timeout() function to lib/upgradelib.php

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.3
    • Fix Version/s: 2.3
    • Component/s: Installation, Libraries
    • Labels:

      Description

      While documenting the Upgrade API (MDL-30981), it has been noticed that the upgrade_set_timeout() function is the only one belonging to that API and not being @ lib/upgradelib.php. Right now it sits @ lib/moodlelib.php.

      So perhaps it would be interesting to move it, so the whole API is in its own lib file.

      Ciao

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              skodak Petr Skoda
              Reporter:
              stronk7 Eloy Lafuente (stronk7)
              Integrator:
              Sam Hemelryk
              Tester:
              Jason Fowler
              Participants:
              Component watchers:
              Matteo Scaramuccia, Andrew Nicols, Jun Pataleta, Michael Hawkins, Shamim Rezaie, Simey Lameze, Amaia Anabitarte, Carlos Escobedo, Ferran Recio, Sara Arjona (@sarjona)
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Fix Release Date:
                25/Jun/12