Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-32295

Edit screen shows "this page" instead of "next page" on matching questions

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Won't Fix
    • Affects Version/s: 2.0.4
    • Fix Version/s: None
    • Component/s: Lesson
    • Labels:
      None
    • Affected Branches:
      MOODLE_20_STABLE

      Description

      When a matching question setting is "next page" on correct answer jump, the edit screen nevertheless shows "this page."

        Gliffy Diagrams

          Activity

          mdubis Mark Dubis created issue -
          mdubis Mark Dubis made changes -
          Field Original Value New Value
          Attachment screenshot-1.jpg [ 27788 ]
          mdubis Mark Dubis made changes -
          Attachment screenshot-2.jpg [ 27789 ]
          timhunt Tim Hunt added a comment -

          The Lesson (still) does not use the standard Moodle question bank, so this is purely a lesson module bug. Reassigning.

          timhunt Tim Hunt made changes -
          Assignee Tim Hunt [ timhunt ] Rossiani Wijaya [ rwijaya ]
          Component/s Lesson [ 10075 ]
          Component/s Questions [ 10087 ]
          sachintha sachintha rajith added a comment -

          Hi all,
          I can't reproduce the bug. It seems it is not existing in Moodle 2.2 versions. Can you give me sime further information to reproduce the bug.

          salvetore Michael de Raadt added a comment -

          Hi, Mark.

          I was not able to reproduce that either. Perhaps you could provide us with some replication steps. It might be worth checking if this same behaviour is replicatable on another system, like demo.moodle.net.

          salvetore Michael de Raadt added a comment -

          I was not able to find an issue that has worked on this area recently, but I will ask Rosie if she knows of any.

          salvetore Michael de Raadt made changes -
          Attachment Showing the desrired behaviour.jpg [ 27805 ]
          salvetore Michael de Raadt added a comment -

          Rosie says she has not made recent changes in this area.

          mdubis Mark Dubis added a comment -

          I am using Moodle 2.0.3. To replicate, create a lesson and then create a matching question page. Leave correct answer jump as default "Next page." Save. Click "Edit" in Lesson Administration navigation bar. Correct answer jump displays as "this page" rather than "next page."

          I have tested this on the demo site at demo.moodle.net and this problem does not occur there, so this bug does not seem to be in Moodle 2.2.1.

          salvetore Michael de Raadt made changes -
          Affects Version/s 2.0.4 [ 10652 ]
          Affects Version/s 2.2.2 [ 11552 ]
          salvetore Michael de Raadt added a comment -

          Hi, Mark.

          Thanks for reporting this.

          I went back and tested this with Moodle 2.1 (our oldest supported version) and it worked correctly. Therefore I assume, if there is a problem, it is not present in supported versions.

          I'm closing this issue and I encourage you to upgrade.

          salvetore Michael de Raadt made changes -
          Status Open [ 1 ] Closed [ 6 ]
          Resolution Won't Fix [ 2 ]

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: