Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-32314

Course pages in moodle look different if anchor is added to the URL

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Trivial
    • Resolution: Not a bug
    • Affects Version/s: 2.2.2
    • Fix Version/s: STABLE backlog
    • Component/s: Themes
    • Labels:
    • Affected Branches:
      MOODLE_22_STABLE

      Description

      This is a tricky bug that I verified in each three columns theme.
      Standard theme is affected by this issue too.

      The issue is this:
      Step 1: Go to a course page.
      Let's say in:
      http://qa.moodle.net/course/view.php?id=4
      (yes, you can get evidence of the issue qa.moodle.net too)

      Step 2: Open a new browser TAB (ctrl-t) and go to the URL
      http://qa.moodle.net/course/view.php?id=4#section-3
      Scroll the page at top.

      The html code is the same but the pages look different.
      To understand where the pages are different switch quickly between the first and the second browser TAB.
      As you can see the central column moves up in the TAB where the URL has the anchor.

      To see this issue better, switch to different three columns themes and perform the same test.

      Here are two more URL to let you better see this problem.
      http://qa.moodle.net/course/view.php?id=4&theme=boxxie
      http://qa.moodle.net/course/view.php?id=4&theme=boxxie#section-3

      http://qa.moodle.net/course/view.php?id=4&theme=formfactor
      http://qa.moodle.net/course/view.php?id=4&theme=formfactor#section-3

        Gliffy Diagrams

        1. with.png
          121 kB
        2. without.png
          103 kB

          Activity

          Hide
          daniss Daniele Cordella added a comment -

          This issue affects Firefox (11) and Safari (5.1.5).
          Chrome is free from this problem.
          I do not know what happen in Opera, Konqueror and IE.

          Show
          daniss Daniele Cordella added a comment - This issue affects Firefox (11) and Safari (5.1.5). Chrome is free from this problem. I do not know what happen in Opera, Konqueror and IE.
          Hide
          salvetore Michael de Raadt added a comment -

          Hi, Daniele.

          I tried this in Firefox 11 (Windows) but I did not see the affect you described.

          Show
          salvetore Michael de Raadt added a comment - Hi, Daniele. I tried this in Firefox 11 (Windows) but I did not see the affect you described.
          Hide
          daniss Daniele Cordella added a comment - - edited

          This is the difference that I see with FF 11 for Mac. As you can see, the "list of topics" (even if it is written in Italian) is missing the vertical alignment whether an anchor is added to the URL

          Show
          daniss Daniele Cordella added a comment - - edited This is the difference that I see with FF 11 for Mac. As you can see, the "list of topics" (even if it is written in Italian) is missing the vertical alignment whether an anchor is added to the URL
          Hide
          lazydaisy Mary Evans added a comment -

          Sounds like the Anchor is too heavy!

          Show
          lazydaisy Mary Evans added a comment - Sounds like the Anchor is too heavy!
          Hide
          lazydaisy Mary Evans added a comment -

          I don't see any changes at all Daniele...could it be the MAC that is causing the odd behaviour?

          Show
          lazydaisy Mary Evans added a comment - I don't see any changes at all Daniele...could it be the MAC that is causing the odd behaviour?
          Hide
          daniss Daniele Cordella added a comment -

          Yes, you may be right.
          I tested it one more time with:
          http://qa.moodle.net/course/view.php?id=2&theme=formfactor
          and
          http://qa.moodle.net/course/view.php?id=2&theme=formfactor#section-3
          and the outcome is:
          mac firefox: the issue is true
          mac safari: the issue is true
          mac chrome: the issue is true
          WXP IE7: the issue is false

          Show
          daniss Daniele Cordella added a comment - Yes, you may be right. I tested it one more time with: http://qa.moodle.net/course/view.php?id=2&theme=formfactor and http://qa.moodle.net/course/view.php?id=2&theme=formfactor#section-3 and the outcome is: mac firefox: the issue is true mac safari: the issue is true mac chrome: the issue is true WXP IE7: the issue is false

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: