Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.4
    • Fix Version/s: 2.4
    • Component/s: Blog, Themes
    • Labels:
    • Testing Instructions:
      Hide
      1. Go to Admin tree -> Appearance -> Blog
      2. Enable useblogassociations, useexternalblogs and blogusecomments
      3. Go to Navigation -> my profile -> blogs, create a blog entry adding a couple of tags and attaching an image file and a non-image file
      4. Go to Navigation -> my profile -> blogs and "View all of my entries", the added entry SHOULD appear, SHOULD contain links to the tags, SHOULD display the attached image and SHOULD show a link to the other attachment
      5. Go to Settings -> My profile settings -> Blogs -> "Register an external blog" and add a blog RSS feed
      6. Go to Navigation -> my profile -> blogs and "View all of my entries", it SHOULD appear your entry/ies with an "edit" link and the external blog entries without "edit" link
      7. Click the "Delete" link of an entry
      8. You SHOULD see the entry, you SHOULD NOT see any exceptions nor debugging messages and you SHOULD see a box below the entry to confirm the delete
      9. Go to a course, turn edition mode on and add the "Blog menu" block
      10. Click "Add an entry about this course" and fill the form
      11. After being redirected to view the entry you SHOULD be able to view a link to the associated course below the entry body and the tags
      12. Go to an activity, turn edition mode on and add the "Blog menu" block
      13. Click "Add an entry about this $MODULENAME" and fill the form
      14. After being redirected to view the entry you SHOULD be able to view a link to the associated activity below the entry body and the tags

      Please, test it with diferent themes and diferent browsers

      ps: a test with RTL in themes to see any effects from this blog change will be useful for creating any further issues .

      Show
      Go to Admin tree -> Appearance -> Blog Enable useblogassociations, useexternalblogs and blogusecomments Go to Navigation -> my profile -> blogs, create a blog entry adding a couple of tags and attaching an image file and a non-image file Go to Navigation -> my profile -> blogs and "View all of my entries", the added entry SHOULD appear, SHOULD contain links to the tags, SHOULD display the attached image and SHOULD show a link to the other attachment Go to Settings -> My profile settings -> Blogs -> "Register an external blog" and add a blog RSS feed Go to Navigation -> my profile -> blogs and "View all of my entries", it SHOULD appear your entry/ies with an "edit" link and the external blog entries without "edit" link Click the "Delete" link of an entry You SHOULD see the entry, you SHOULD NOT see any exceptions nor debugging messages and you SHOULD see a box below the entry to confirm the delete Go to a course, turn edition mode on and add the "Blog menu" block Click "Add an entry about this course" and fill the form After being redirected to view the entry you SHOULD be able to view a link to the associated course below the entry body and the tags Go to an activity, turn edition mode on and add the "Blog menu" block Click "Add an entry about this $MODULENAME" and fill the form After being redirected to view the entry you SHOULD be able to view a link to the associated activity below the entry body and the tags Please, test it with diferent themes and diferent browsers ps: a test with RTL in themes to see any effects from this blog change will be useful for creating any further issues .
    • Affected Branches:
      MOODLE_24_STABLE
    • Fixed Branches:
      MOODLE_24_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      MDL-32344_master

      Description

      Blog pages use tables to layout single blog texts. This is very bad from theming perspective. Could tables be replaced with divs?

      The rendering is done in /blog/locallib.php in function print_html().

        Gliffy Diagrams

          Issue Links

            Activity

            juonio Juho Viitasalo created issue -
            juonio Juho Viitasalo made changes -
            Field Original Value New Value
            Issue Type Bug [ 1 ] Improvement [ 4 ]
            phalacee Jason Fowler made changes -
            Assignee moodle.com [ moodle.com ] Jason Fowler [ phalacee ]
            phalacee Jason Fowler made changes -
            Fix Version/s STABLE Sprint 20 [ 12152 ]
            phalacee Jason Fowler made changes -
            Affects Version/s 2.3 [ 10657 ]
            Affects Version/s 2.2.2 [ 11552 ]
            Affects Version/s 2.2.3 [ 12053 ]
            phalacee Jason Fowler made changes -
            Labels triaged
            phalacee Jason Fowler made changes -
            Fix Version/s STABLE backlog [ 10463 ]
            Fix Version/s STABLE Sprint 20 [ 12152 ]
            phalacee Jason Fowler made changes -
            Fix Version/s STABLE Sprint 22 [ 12156 ]
            Fix Version/s STABLE backlog [ 10463 ]
            dmonllao David Monllaó made changes -
            Assignee Jason Fowler [ phalacee ] David Monllaó [ davmon ]
            dmonllao David Monllaó made changes -
            Assignee David Monllaó [ davmon ] Jason Fowler [ phalacee ]
            dmonllao David Monllaó made changes -
            Assignee Jason Fowler [ phalacee ] David Monllaó [ davmon ]
            dmonllao David Monllaó made changes -
            Status Open [ 1 ] Development in progress [ 3 ]
            dmonllao David Monllaó made changes -
            Testing Instructions # Go to Admin tree -> Appearance -> Blog
            # Enable useblogassociations, useexternalblogs and blogusecomments
            # Go to Navigation -> my profile -> blogs, create a blog entry adding a couple of tags and attaching an image file and a non-image file
            # Go to Navigation -> my profile -> blogs and "View all of my entries", the added entry SHOULD appear, SHOULD contain links to the tags, SHOULD display the attached image and SHOULD show a link to the other attachment
            # Go to Settings -> My profile settings -> Blogs -> "Register an external blog" and add a blog RSS feed
            # Go to Navigation -> my profile -> blogs and "View all of my entries", it SHOULD appear your entry/ies with an "edit" link and the external blog entries without "edit" link
            # Click the "Delete" link of an entry
            # You SHOULD see the entry, you SHOULD NOT see any exceptions nor debugging messages and you SHOULD see a box below the entry to confirm the delete
            # Go to a course, turn edition mode on and add the "Blog menu" block
            # Click "Add an entry about this course" and fill the form
            # After being redirected to view the entry you SHOULD be able to view a link to the associated course below the entry body and the tags
            # Go to an activity, turn edition mode on and add the "Blog menu" block
            # Click "Add an entry about this $MODULENAME" and fill the form
            # After being redirected to view the entry you SHOULD be able to view a link to the associated activity below the entry body and the tags

            Please, test it with diferent themes and diferent browsers
            dmonllao David Monllaó made changes -
            Status Development in progress [ 3 ] Waiting for peer review [ 10012 ]
            Pull Master Diff URL https://github.com/dmonllao/moodle/compare/master...MDL-32344_master
            Pull Master Branch MDL-32344_master
            Pull from Repository git://github.com/dmonllao/moodle.git
            phalacee Jason Fowler made changes -
            Original Estimate 0 minutes [ 0 ]
            Remaining Estimate 0 minutes [ 0 ]
            Status Waiting for peer review [ 10012 ] Peer review in progress [ 10013 ]
            Peer reviewer phalacee
            phalacee Jason Fowler made changes -
            Status Peer review in progress [ 10013 ] Development in progress [ 3 ]
            dmonllao David Monllaó made changes -
            Status Development in progress [ 3 ] Waiting for integration review [ 10010 ]
            samhemelryk Sam Hemelryk made changes -
            Currently in integration Yes [ 10041 ]
            nebgor Aparup Banerjee made changes -
            Status Waiting for integration review [ 10010 ] Integration review in progress [ 10004 ]
            Integrator nebgor
            nebgor Aparup Banerjee made changes -
            Status Integration review in progress [ 10004 ] Reopened [ 4 ]
            cibot CiBoT made changes -
            Status Reopened [ 4 ] Reopened [ 4 ]
            Currently in integration Yes [ 10041 ]
            dmonllao David Monllaó made changes -
            Status Reopened [ 4 ] Development in progress [ 3 ]
            dmonllao David Monllaó made changes -
            Fix Version/s STABLE Sprint 23 [ 12358 ]
            Fix Version/s STABLE Sprint 22 [ 12156 ]
            dmonllao David Monllaó made changes -
            Status Development in progress [ 3 ] Waiting for integration review [ 10010 ]
            poltawski Dan Poltawski made changes -
            Currently in integration Yes [ 10041 ]
            nebgor Aparup Banerjee made changes -
            Status Waiting for integration review [ 10010 ] Integration review in progress [ 10004 ]
            nebgor Aparup Banerjee made changes -
            Labels triaged triaged ui_change
            nebgor Aparup Banerjee made changes -
            Testing Instructions # Go to Admin tree -> Appearance -> Blog
            # Enable useblogassociations, useexternalblogs and blogusecomments
            # Go to Navigation -> my profile -> blogs, create a blog entry adding a couple of tags and attaching an image file and a non-image file
            # Go to Navigation -> my profile -> blogs and "View all of my entries", the added entry SHOULD appear, SHOULD contain links to the tags, SHOULD display the attached image and SHOULD show a link to the other attachment
            # Go to Settings -> My profile settings -> Blogs -> "Register an external blog" and add a blog RSS feed
            # Go to Navigation -> my profile -> blogs and "View all of my entries", it SHOULD appear your entry/ies with an "edit" link and the external blog entries without "edit" link
            # Click the "Delete" link of an entry
            # You SHOULD see the entry, you SHOULD NOT see any exceptions nor debugging messages and you SHOULD see a box below the entry to confirm the delete
            # Go to a course, turn edition mode on and add the "Blog menu" block
            # Click "Add an entry about this course" and fill the form
            # After being redirected to view the entry you SHOULD be able to view a link to the associated course below the entry body and the tags
            # Go to an activity, turn edition mode on and add the "Blog menu" block
            # Click "Add an entry about this $MODULENAME" and fill the form
            # After being redirected to view the entry you SHOULD be able to view a link to the associated activity below the entry body and the tags

            Please, test it with diferent themes and diferent browsers
            # Go to Admin tree -> Appearance -> Blog
            # Enable useblogassociations, useexternalblogs and blogusecomments
            # Go to Navigation -> my profile -> blogs, create a blog entry adding a couple of tags and attaching an image file and a non-image file
            # Go to Navigation -> my profile -> blogs and "View all of my entries", the added entry SHOULD appear, SHOULD contain links to the tags, SHOULD display the attached image and SHOULD show a link to the other attachment
            # Go to Settings -> My profile settings -> Blogs -> "Register an external blog" and add a blog RSS feed
            # Go to Navigation -> my profile -> blogs and "View all of my entries", it SHOULD appear your entry/ies with an "edit" link and the external blog entries without "edit" link
            # Click the "Delete" link of an entry
            # You SHOULD see the entry, you SHOULD NOT see any exceptions nor debugging messages and you SHOULD see a box below the entry to confirm the delete
            # Go to a course, turn edition mode on and add the "Blog menu" block
            # Click "Add an entry about this course" and fill the form
            # After being redirected to view the entry you SHOULD be able to view a link to the associated course below the entry body and the tags
            # Go to an activity, turn edition mode on and add the "Blog menu" block
            # Click "Add an entry about this $MODULENAME" and fill the form
            # After being redirected to view the entry you SHOULD be able to view a link to the associated activity below the entry body and the tags

            Please, test it with diferent themes and diferent browsers

            ps: a test with RTL in themes to see any effects from this blog change will be useful for creating any further issues :-).
            nebgor Aparup Banerjee made changes -
            Status Integration review in progress [ 10004 ] Waiting for testing [ 10005 ]
            Affects Version/s 2.4 [ 12255 ]
            Affects Version/s 2.3 [ 10657 ]
            Fix Version/s 2.4 [ 12255 ]
            nebgor Aparup Banerjee made changes -
            Labels triaged ui_change dev_docs_required triaged ui_change
            dmonllao David Monllaó made changes -
            Link This issue testing discovered MDL-34869 [ MDL-34869 ]
            timb Tim Barker made changes -
            Tester salvetore
            salvetore Michael de Raadt made changes -
            Status Waiting for testing [ 10005 ] Testing in progress [ 10011 ]
            salvetore Michael de Raadt made changes -
            Status Testing in progress [ 10011 ] Tested [ 10006 ]
            stronk7 Eloy Lafuente (stronk7) made changes -
            Status Tested [ 10006 ] Closed [ 6 ]
            Resolution Fixed [ 1 ]
            Currently in integration Yes [ 10041 ]
            Integration date 16/Aug/12
            salvetore Michael de Raadt made changes -
            Labels dev_docs_required triaged ui_change triaged
            rajeshtaneja Rajesh Taneja made changes -
            Link This issue has a non-specific relationship to MDL-37245 [ MDL-37245 ]
            stronk7 Eloy Lafuente (stronk7) made changes -
            Fix Version/s STABLE Sprint 23 Alpha [ 12358 ]

              People

              • Votes:
                1 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  3/Dec/12