Moodle
  1. Moodle
  2. MDL-32356

Add a new setting to formal_white to allow users to modify the margin of the blocks in the columns.

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.2.2
    • Fix Version/s: 2.3
    • Component/s: Themes
    • Labels:
    • Rank:
      39179

      Description

      To provide the community a theme that is customizable as much as it can be, it would be nice to add to formal_white a new setting to define block margins.

        Activity

        Daniele Cordella created issue -
        Daniele Cordella made changes -
        Field Original Value New Value
        Assignee Patrick Malley [ ptrkmkl ] Daniele Cordella [ daniss ]
        Daniele Cordella made changes -
        Status Open [ 1 ] Waiting for peer review [ 10012 ]
        Pull Master Diff URL https://github.com/kordan/moodle/compare/master...MDL-32356_master
        Pull Master Branch MDL-32356_master
        Pull from Repository git://github.com/kordan/moodle.git
        Dan Poltawski added a comment -

        Hi Mary,

        I've assigned another theme issue looking for peer review - again if you are not able to look at this just yell at me
        thanks,
        dan

        Dan Poltawski made changes -
        Peer reviewer lazydaisy
        Mary Evans added a comment - - edited

        @Daniele

        This line needs fixing the CSS is wrong...

        .block {border:1px #C6BDA8 solid;margin-bottom:[[setting:blockpadding]];}
        

        it should look like this...

        .block {border:1px solid #C6BDA8;margin-bottom:[[setting:blockpadding]];}
        

        Also this line is adding a standard margin to the bottom of the block. Does this actually need to be a setting?

        The other setting which changes .region-content is fine.

        The problem with Canvas as a parent theme is caused by the fact you still have the parent theme back to front. The parent theme array should be as follows:

        $THEME->parents = array('canvas', 'base')
        

        I'll do the testing later today. I'm on a late-shift here so I may not surface until late afternoon if I ever get to bed! With luck we can get this in for integration if they are doing themes this weekend

        Ciao

        Daniele Cordella added a comment - - edited

        Ciao Mary.
        about: .block

        {border:1px #C6BDA8 solid;margin-bottom:[[setting:blockpadding]];}

        of course, you are right. No need to ask for corrections.

        about: Does this actually need to be a setting?
        Yes, I believe it is needed because of homogeneity of the frame around blocks it ensure.

        about the order of parents: I could have sworn you already reverted their order some months ago! If you feel it is ok to swap them, I trust you.

        Finally: thanks for your work. Ciao.

        Mary Evans added a comment - - edited

        No, you were going to do this when you did the changes for the page margin width settings, but didn't!

        Can you please change that CSS rule to read..."border:1px #C6BDA8 solid;" you have the wrong order, which in this instance does matter. Correct order is:

        border: width style color;
        

        After you correct that you can set this for integration.

        Thanks
        Mary

        Daniele Cordella added a comment -

        I did it just now.
        Following your suggestion I corrected few more instances of wrong order of style and color in the theme.
        All are now corrected.
        Thanks Mary.

        Daniele Cordella added a comment -

        Submit for integration as of the comment from Mary at 12/apr/12 3:48 PM

        Daniele Cordella made changes -
        Status Waiting for peer review [ 10012 ] Waiting for integration review [ 10010 ]
        Dan Poltawski added a comment -

        The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

        TIA and ciao

        Sam Hemelryk made changes -
        Currently in integration Yes [ 10041 ]
        Sam Hemelryk made changes -
        Status Waiting for integration review [ 10010 ] Integration review in progress [ 10004 ]
        Integrator samhemelryk
        Sam Hemelryk added a comment -

        Thanks Daniele, this has been integrated now

        Sam Hemelryk made changes -
        Status Integration review in progress [ 10004 ] Waiting for testing [ 10005 ]
        Fix Version/s 2.3 [ 10657 ]
        Michael de Raadt made changes -
        Labels triaged
        Jason Fowler made changes -
        Status Waiting for testing [ 10005 ] Testing in progress [ 10011 ]
        Tester phalacee
        Jason Fowler added a comment -

        looks good and works well

        Jason Fowler made changes -
        Status Testing in progress [ 10011 ] Tested [ 10006 ]
        Dan Poltawski added a comment -

        Bonza mate!

        Your changes have made it into the Moodle release! Its time to celebrate! Put a shrimp on the barbie and grab a stubby.

        Hooroo

        Dan Poltawski made changes -
        Status Tested [ 10006 ] Closed [ 6 ]
        Resolution Fixed [ 1 ]
        Currently in integration Yes [ 10041 ]
        Dan Poltawski made changes -
        Integration date 19/Apr/12

          People

          • Votes:
            1 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: