Moodle
  1. Moodle
  2. MDL-32552

Feedback module is not saving couse id in table mdl_feedback_value

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Not a bug
    • Affects Version/s: 1.9.15
    • Fix Version/s: None
    • Component/s: Feedback
    • Labels:
      None
    • Affected Branches:
      MOODLE_19_STABLE
    • Rank:
      39458

      Description

      I was trying to build a SQL report when I notice that table mdl_feedback_value has a column 'course_id' but only 0 are getting stored into it. Why id this? Is this a bug? It would make my report a lot easier if the true course id was stored there correctly.

      Can anybody help, what is supposed to happen to column 'course_id' ?

      I know feed back was not core in 1.9.x but I had no better place to post this, sorry.

        Activity

        Andreas Grabs added a comment -

        Hi John,

        this is not a bug. The field course_id in the values table is used if you use a centrally defined feedback with the feedback-block.
        There is a forum in moodle.org (http://moodle.org/mod/forum/view.php?id=7152) where you could ask for more details. So more user can participate.

        Best regards
        Andreas

        John Anderson added a comment -

        Hey, thanks Andreas - at least I know now. And "centrally defined feedback with the feedback-block." Sounds like maybe what I should be doing. Closed up.


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: