Moodle
  1. Moodle
  2. MDL-32582

MP3 Flow Player doesn't work in Chrome if empty stylesheets are present

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Duplicate
    • Affects Version/s: 2.0.8, 2.1.5, 2.2.2
    • Fix Version/s: None
    • Component/s: Filters
    • Labels:
    • Testing Instructions:

      Whilst Moodle itself generally won't include empty stylesheets, some Chrome extensions (including Google's screenshot tool, https://chrome.google.com/webstore/detail/cpngackimfmofbokmjmljamhdncknpmg) can inject empty stylesheets into the page - the aforementioned screenshot tool was the culprit in my case. I guess that's one way to test this - install that extension (it's handy to have anyway!).

      Show
      Whilst Moodle itself generally won't include empty stylesheets, some Chrome extensions (including Google's screenshot tool, https://chrome.google.com/webstore/detail/cpngackimfmofbokmjmljamhdncknpmg ) can inject empty stylesheets into the page - the aforementioned screenshot tool was the culprit in my case. I guess that's one way to test this - install that extension (it's handy to have anyway!).
    • Difficulty:
      Easy
    • Affected Branches:
      MOODLE_20_STABLE, MOODLE_21_STABLE, MOODLE_22_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      MDL-32582_master
    • Rank:
      39498

      Description

      If any empty stylesheets are present, Chrome will not display the MP3 Flow Player. This is similar to MDL-29980, though happened after the MDL-26697 changes were merged.

      A quick and easy fix is to add the following line just after line 1712 of /lib/javascript-static.js (as per current master) - i.e. between the if and the for loop:

      if (!allrules) continue;
      

        Issue Links

          Activity

          Paul Nicholls added a comment -

          Added pull details

          Michael de Raadt added a comment -

          Thanks for spotting that and providing a fix.

          Michael de Raadt added a comment -

          This looks like a duplicate of an earlier issue, although you may have solved the cause of the mystery. I'm going to close this issue. Please contribute to the linked duplicate issue.


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: