Moodle
  1. Moodle
  2. MDL-32591

Lesson Module - 3rd page setup as Multiple Choice Quiz - Report shows wrong grade no matter the answer given.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.2.2
    • Fix Version/s: None
    • Component/s: Lesson
    • Labels:
    • Affected Branches:
      MOODLE_22_STABLE
    • Rank:
      39512

      Description

      When testing a lesson for a client we found that if the 3rd page is setup as a multiple choice question page no matter what answer is given by the user the Report shows that the user got the question wrong. The following information is the lesson setup and I attached the backup of my test to the tracker.

      Testing Instructions:

      1] Create a Course
      2] Create a Lesson. The following settings are not default:

      Re-takes allowed - Yes
      Handling of re-takes - Use maximum
      Display ongoing score - No
      Allow student review - Yes
      Provide option to try a question again - Yes
      Display default feedback - Yes
      Progress bar - Yes
      Display left menu - Yes

      3] Create 3 or more pages in the lesson

      • Page 1 & 2 should be content pages. Settings left at default.
      • Page 3 should be a Multiple Choice Question page. Settings for each question are as follows:
        + Answer - (Your choice)
        + Drop down - Moodle auto-format
        + Response - (Your choice)
        + Drop down - Moodle auto-format
        + Jump - Next page
        + Score - 1
        Note: Our question page had three possible correct answers.

      4] Login as a student.
      5] Attempt the lesson as a Student. Provide the correct answer when on the Question Page.
      6] As the student review your grade. It should be 100%
      7] Log out and log back in as an admin.
      8] Review the Report tab of the lesson.
      9] Check the attempt the student user just made.
      10] Although the student receives the correct score the Report shows the following:

      • Response: That's the wrong answer
      • Points earned: 0

        Issue Links

          Activity

          Michael de Raadt added a comment -

          Hi, Joseph.

          Does that only happen when the question page is the third page? Have you tried adding other pages around it?

          Joseph Jacelone added a comment -

          Hey Michael!

          All question pages past the third work fine. During my testing I had not tried setting it up with a question page before the third. I will do that today and report back.

          Joseph

          Michael de Raadt added a comment -

          Thanks for continuing with this.

          Please post your findings. I'll put this on the backlog.

          In the meantime, if you are able to find a solution and add a patch, please do so. Add a 'patch' label if you do.

          Michael de Raadt added a comment -

          Just a note for the people who voted for this issue from Remote-Learner: as this is a stable issue, voting won't really push it through any quicker. Your 'partner' label has more influence there anyway.

          Rossiani Wijaya added a comment -

          Hi Joseph,

          I'm looking at this issue and get confused with the description and backup file.

          In your backup file, the 3rd page is a short answer question, while your report mentioned it is related to multiple choice question.

          I did some testing and found the following:

          1. Setup 3rd page as multiple choice question, attempted as student and checked the attempt. It displayed the correct report.
          2. Setup 3rd or 4th page as short answer question, attempted correctly as student and checked the attempt. The report displayed the wrong response. This is incorrect and has been reported through MDL-34011.

          Could you please clarified which question page is displaying the wrong report?

          Thanks.
          Rosie

          Rossiani Wijaya added a comment -

          Hi Joseph,

          Any chance you could clarify this issue?

          Rossiani Wijaya added a comment -

          I can't replicate the bug for multiple choice as it stated on the title and description.

          Instead I fixed the bug that occurs on short answer attempt. This fixed is done through MDL-34011.

          I'm closing this issue as can't reproduce.

          Please feel free to report new issue if this still occurs.


            People

            • Votes:
              8 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: