Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-32612

Moodle 2.3 upgrade not auto-scrolling (2 js errors in console)

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.3
    • Fix Version/s: 2.3
    • Component/s: Installation, Libraries
    • Labels:
    • Testing Instructions:

      for developers:
      1/ add some trigger_error() after require config.php to lib/javascript.php
      2/ reload page
      3/ notice expected only in error_log, not in page output
      4/ try install and upgrade - look for broken JS

      Show
      for developers: 1/ add some trigger_error() after require config.php to lib/javascript.php 2/ reload page 3/ notice expected only in error_log, not in page output 4/ try install and upgrade - look for broken JS
    • Affected Branches:
      MOODLE_23_STABLE
    • Fixed Branches:
      MOODLE_23_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      w18_MDL-32612_m23_debug

      Description

      Just detected some days ago that, under master, I was not getting the auto-scroll-to-bottom anymore. Looking to it, I detected 2 JS errors that may be causing this:

      • "javascript.php" unexpected token "<" at line 1. And it seems it's cause because I'm getting one stack trace there (instead of clean js) with this error: "failed to open stream: No such file or directory in lib/minify/lib/Minify/Cache/File.php on line 100"
      • TypeError: 'undefined' is not an object (evaluating 'M.util.load_flowplayer')

      I guess they prevent the auto-scroll to happen. Ciao

        Gliffy Diagrams

          Attachments

            Activity

            stronk7 Eloy Lafuente (stronk7) added a comment -

            (adding Petr and SamH here)

            skodak Petr Skoda added a comment -

            Hopefully this should eliminate the broken output caused by notices. Hopefully we will find the cause of the notices later, there seems to be something wrong going on in minifier, but I think it does not affect the results...

            stronk7 Eloy Lafuente (stronk7) added a comment -

            The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

            TIA and ciao

            samhemelryk Sam Hemelryk added a comment -

            Thanks Petr, has been integrated now

            phalacee Jason Fowler added a comment -

            works fine Petr, thanks for the clear testing instructions

            stronk7 Eloy Lafuente (stronk7) added a comment -

            UPDATE tracker_issues
               SET status = 'Closed',
                  comment = 'Thanks!'
            WHEN participants = 'Did a gorgeous work'

            This landed upstream some hours ago (some - me - developer fell slept in the sofa yesterday before spamming this).


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  25/Jun/12