Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-32617

Using course layout with question bank

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor
    • Resolution: Not a bug
    • Affects Version/s: 2.2.2
    • Fix Version/s: None
    • Component/s: Questions, Themes
    • Labels:
      None
    • Affected Branches:
      MOODLE_22_STABLE

      Description

      Question bank page is using admin layout. I don't understand why because question bank is used in course context.

      question/editlib.php on line 1613:

      $PAGE->set_pagelayout('admin');

        Gliffy Diagrams

          Attachments

            Activity

            timhunt Tim Hunt added a comment -

            Yes, that was done on purpose. See MDL-28437 and http://tracker.moodle.org/browse/MDL-28437.

            These pages are not parts that students see when studying the course. They are parts that teachers see when administering the course. So, like many of the other links in the course and quiz settings, it is page layout admin.

            I am unlikely to change it back unless you can start a discussion in the Themes forum that convinces a majority of people there that the current behaviour is wrong.

            juonio Juho Viitasalo added a comment -

            Thanks for pointing that out!

            timhunt Tim Hunt added a comment -

            So, can I close this issue as 'Not a bug' or 'Won't fix' or something like that?

            timhunt Tim Hunt added a comment -

            Closing.

            juonio Juho Viitasalo added a comment -

            Ok by me!


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: