Moodle
  1. Moodle
  2. MDL-32635

In lesson, last attempt warning does not appear when a maximum number of attempts is activated

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Not a bug
    • Affects Version/s: 2.2.1, 2.3.4, 2.4.1, 2.5
    • Fix Version/s: None
    • Component/s: Lesson
    • Labels:
    • Affected Branches:
      MOODLE_22_STABLE, MOODLE_23_STABLE, MOODLE_24_STABLE, MOODLE_25_STABLE

      Description

      MDLQA-1022
      This test requires a lesson activity containing more than one question.

      1. Login as a teacher, update a lesson activity and set 'Display review button' to No and the maximum number of attempts to 2.
      2. Login as a student and attempt the activity.
      3. Answer a question wrongly and and check that the message 'You have 1 attempt(s) remaining' is displayed.
      4. Click the continue button and answer the question wrongly again.
      5. Check that you are no longer allowed to attempt the question.

      In step 3, the message never appears to the user.

        Gliffy Diagrams

          Activity

          Michael de Raadt added a comment -

          Thanks for reporting this.

          I've put that on the backlog.

          In the meantime feel free to help us work on this issue. If you are able to provide a patch, please add a patch label so we will spot it.

          Melvin Romero added a comment -

          This is still present in Moodle 2.3.2 and 2.4.

          Rossiani Wijaya added a comment -

          Hi Melvin,

          Could you check the lesson setting for 'Re-takes allowed' is set to 'yes'?

          Let me know if it works for you.

          Rosie

          Melvin Romero added a comment -

          Hello Rossiani,

          I've tried again on 2.3.2 (which we will use in my university) and even with the setting set to yes, the message still does not appear. We have a vanilla version installed as well and it is the same result... Is there something I'm doing wrong ?

          However, I will try it on the 2.5 DEV and come back with a feedback.

          Thank you for your fast response.

          Rossiani Wijaya added a comment -

          Hi Melvin,

          Have you managed to make this works in 2.5?

          This is what I used to test the issue:

          1. Create lesson
          2. Set Display review button' to No, Re-takes allowed to yes, and the maximum number of attempts to 2
          3. Add a multiple choices question page
          4. Add page title and description
          5. Answer 1: set the correct answer, set a response, set jump to 'next page', and score to 1
          6. Answer 2: set the wrong answer, set a response, set jump to 'this page', and score to 0
          7. Answer 3: set the wrong answer, set a response, set jump to 'this page', and score to 0
          8. Save the page
          9. As student, attempt the question by selecting the wrong answer.

          You will see the message 'You have 1 attempt(s) remaining' is displayed.

          Please let me know if this works for you.

          Thanks
          Rosie

          Melvin Romero added a comment -

          Hi,

          I've juste tested this ^on 2.5. It still dosen't show the message... I followed all your steps and for some reason I don't get the "You have 1 attempt(s) remaining". I posted a screenshot showing my settings. Let me know if I set it correctly.

          Thanks
          Melvin

          Rossiani Wijaya added a comment -

          Hi Melvin,

          Could you try the attached backup file and let me know if it works for you.

          Thanks.
          Rosie

          Rossiani Wijaya added a comment -

          Hi Melvin,

          Did you get a chance to test the backup file?

          Melvin Romero added a comment -

          Hi Rossiani,

          Your file worked. The message is shown. I will test with the same settings on 2.3.2. I'll give you some feedback when I am able.

          Thanks for your help !

          Rossiani Wijaya added a comment -

          Closing this issue as not a bug.

          Please feel free to create new issue if there's any related bug to this.

          Closed.


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: