Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-32676

use cached combo loading for yui3 bootstrapping

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.2
    • Fix Version/s: 2.3
    • Component/s: Libraries
    • Labels:

      Description

      at the moment it is always loaded as:

       $code .= '<script type="text/javascript" src="'.$this->yui3loader->base.'yui/yui-min.js"></script>';

      the problem is it is not cached properly in browser.

      Safari says: The following resources are missing a cache expiration. Resources that do not specify an expiration may not be cached by browsers.

        Gliffy Diagrams

          Attachments

            Activity

            skodak Petr Skoda created issue -
            skodak Petr Skoda added a comment -

            This could reduce JS init time in some cases.

            skodak Petr Skoda made changes -
            Field Original Value New Value
            Status Open [ 1 ] Waiting for integration review [ 10010 ]
            Pull Master Diff URL https://github.com/skodak/moodle/compare/master...w18_MDL-32676_m23_yuibootstrap
            Pull Master Branch w18_MDL-32676_m23_yuibootstrap
            Pull from Repository git://github.com/skodak/moodle.git
            Fix Version/s 2.3 [ 10657 ]
            Testing Instructions 1/ enable yui combo loading and test if JS works
            2/ disable yui combo loading and test if JS works
            3/ repeat with external YUI libs
            skodak Petr Skoda made changes -
            Description at the moment it is always loaded as:
            {code}
             $code .= '<script type="text/javascript" src="'.$this->yui3loader->base.'yui/yui-min.js"></script>';
            {code}

            the problem is it is not cached properly in browser...
            at the moment it is always loaded as:
            {code}
             $code .= '<script type="text/javascript" src="'.$this->yui3loader->base.'yui/yui-min.js"></script>';
            {code}

            the problem is it is not cached properly in browser.

            Safari says: The following resources are missing a cache expiration. Resources that do not specify an expiration may not be cached by browsers.
            samhemelryk Sam Hemelryk made changes -
            Currently in integration Yes [ 10041 ]
            samhemelryk Sam Hemelryk made changes -
            Status Waiting for integration review [ 10010 ] Integration review in progress [ 10004 ]
            Integrator samhemelryk
            samhemelryk Sam Hemelryk added a comment -

            Thanks Petr - this has been integrated now

            samhemelryk Sam Hemelryk made changes -
            Status Integration review in progress [ 10004 ] Waiting for testing [ 10005 ]
            salvetore Michael de Raadt made changes -
            Labels triaged
            salvetore Michael de Raadt added a comment -

            Note for tester: These two settings are site settings. Search for YUI in the admin block.

            abgreeve Adrian Greeve made changes -
            Status Waiting for testing [ 10005 ] Testing in progress [ 10011 ]
            Tester abgreeve
            abgreeve Adrian Greeve added a comment -

            Tested with yui combo loading enabled and disabled, and then same again with external yui libraries. No problems encountered.
            Thanks.

            abgreeve Adrian Greeve made changes -
            Status Testing in progress [ 10011 ] Tested [ 10006 ]
            stronk7 Eloy Lafuente (stronk7) added a comment -

            UPDATE tracker_issues
               SET status = 'Closed',
                  comment = 'Thanks!'
            WHEN participants = 'Did a gorgeous work'

            This landed upstream some hours ago (some - me - developer fell slept in the sofa yesterday before spamming this).

            stronk7 Eloy Lafuente (stronk7) made changes -
            Status Tested [ 10006 ] Closed [ 6 ]
            Resolution Fixed [ 1 ]
            Currently in integration Yes [ 10041 ]
            Integration date 04/May/12

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  25/Jun/12