Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Duplicate
    • Affects Version/s: 2.3
    • Fix Version/s: None
    • Component/s: Web Services
    • Labels:

      Description

      Dan reported the following php warning in his log:

      Strict standards: Creating default object from empty value in /Users/danp/git/integration/admin/webservice/forms.php on line 80 Call Stack: 0.0013 686064 1.

      Unknown macro: {main}

      () /Users/danp/git/integration/admin/webservice/service.php:0 0.3635 14195048 2. moodleform->moodleform() /Users/danp/git/integration/admin/webservice/service.php:66 0.3645 14213168 3. external_service_form->definition() /Users/danp/git/integration/lib/formslib.php:166

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              jerome Jérôme Mouneyrac added a comment - - edited

              Rosie if you are ok with this, you can send it straight to integration.

              Integrators: cherry-pick in 2.1/2.2 too. I check the code is still the same in 2.1 so you should not have any conflict.

              rwijaya Rossiani Wijaya added a comment -

              Hi Jerome,

              The patch looks good. Just a very tiny fix needed on the spacing for it.

              Other than that, its all good.

              jerome Jérôme Mouneyrac added a comment - - edited

              Thanks Rosie, submitting.

              Integrators: cherry-pick in 2.1/2.2 too. I check the code is still the same in 2.1 so you should not have any conflict.

              poltawski Dan Poltawski added a comment -

              Hi Jerome,

              Looks like Eloy beat you to it in MDL-32786..

              Note that we are not fixing E_STRICT errors on the stable branches, only 2.3 as there are many errors not yet fixed there.

              poltawski Dan Poltawski added a comment -

              Closing as duplicate of MDL-32786


                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  0 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: