Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-32707

media filter youtube videos should be transparent

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.1.5
    • Fix Version/s: 2.3
    • Component/s: Filters
    • Labels:
    • Testing Instructions:

      Testing could be tricky as you'll need something you know is currently affected such as the Module Chooser (MDL-30617).

      • Enable the Media filter and Youtube repository plugin.
      • Add a Label to a course
      • Add a youtube video – I tend to use this fun video: http://www.youtube.com/watch?v=KOyQBSMeIhM – cracks me up every time
      • Trigger something (such as a Moodle dialogue or exception) which will show something in front of the youtube video
      Show
      Testing could be tricky as you'll need something you know is currently affected such as the Module Chooser ( MDL-30617 ). Enable the Media filter and Youtube repository plugin. Add a Label to a course Add a youtube video – I tend to use this fun video: http://www.youtube.com/watch?v=KOyQBSMeIhM – cracks me up every time Trigger something (such as a Moodle dialogue or exception) which will show something in front of the youtube video
    • Difficulty:
      Easy
    • Affected Branches:
      MOODLE_21_STABLE
    • Fixed Branches:
      MOODLE_23_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      MDL-32707-master-1

      Description

      Youtube videos displayed by the media filter often show through things menus in front of them.
      This is particularly obvious with the Module Chooser and the new Drag/Drop.

      We need to add &wmode=transparent to the iframe src for youtube videos

        Gliffy Diagrams

          Issue Links

            Activity

            dobedobedoh Andrew Nicols added a comment -

            This patch should cherry-pick cleanly to all stable branches.

            kabalin Ruslan Kabalin added a comment - - edited

            Thanks Andrew, this is particularly important for drag-drop and overlay windows.
            +1 from me.

            poltawski Dan Poltawski added a comment -

            You might want to keep an eye on the status of http://tracker.moodle.org/browse/MDL-29624

            dobedobedoh Andrew Nicols added a comment -

            Hmm - thanks for pointing that out. I'd forgotten that was in integration this week. Would you prefer a patch against MDL-29624 instead, or should I wait until next week?

            poltawski Dan Poltawski added a comment -

            You have to see if it makes it..

            nebgor Aparup Banerjee added a comment -

            just squeezing this in.

            nebgor Aparup Banerjee added a comment -

            Thanks, thats been merged into lib/medialib.php within class core_media_player_youtube{}

            i've used any page with a file picker and added a html block with that hilarious youtube in it.

            replicated tested integrated into master

            fred Frédéric Massart added a comment -

            I have tried to test and it looks like it works, but I am not sure about the testing instruction.
            Could you clarify how to trigger a Moodle Dialogue or Exception from the course page?

            Thanks!

            poltawski Dan Poltawski added a comment -

            OK, we want to role the releases and for all purposes this seems to be working with no regressions so I am passing this. Though we are confused on how to demonstrate it.

            Please if you can give instructions on how to trigger this for a tester in future that'd be great.

            dobedobedoh Andrew Nicols added a comment -

            Well, I was hoping that the modchooser was going to be integrated as this gives a really easy way of demonstrating the issue. I'll see if there's another way I can find in the mean time...

            stronk7 Eloy Lafuente (stronk7) added a comment -

            This is now part of Moodle and a few millions people around the globe will be using it soon. Isn't that awesome?

            Many, many thanks and don't forget http://youtu.be/4N7dPaP5Z8U

            Closing, ciao

            nebgor Aparup Banerjee added a comment -

            I've spoken to Fred about what i meant, just to share how i tested:

            i turned editing mode on, went into a modules page (advanced assignment type grading page) which had a filepicker to use to pop up a dialog. on that page with a file picker , i added a html block and added a youtube video to it. then i popped up the file picker dialog and dragged it over the block containing youtube video. there done


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  25/Jun/12