Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-32713

Feedback notifications emails are sent to site-level Managers

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Not a bug
    • Affects Version/s: 2.2.2
    • Fix Version/s: None
    • Component/s: Feedback
    • Labels:
      None
    • Affected Branches:
      MOODLE_22_STABLE

      Description

      We have a course that is using the feedback module with the email notification option turned on.

      When the editingteacher for that course enabled that option, we expected that only users with the mod/feedback:receiveemail capability at the course level would get a notice, but it appears that everyone listed in Settings > Course administration > Users > Other users are also getting the email notification.

      We tried added in a prevent and prohibit for the mod/feedback:receiveemail capability, but they are still getting email notices.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              rex Rex Lorenzo added a comment -

              Please close ticket. The problem was not the Feedback module, but the Assignments module. With email notifications turned on for assignment our site level users were getting emailed, because they have the capability to grade.

              salvetore Michael de Raadt added a comment -

              Closed at reporter's request.


                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  1 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: