Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-32752

Course drag-drop, missing target

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.3
    • Fix Version/s: 2.3
    • Component/s: Course, JavaScript
    • Labels:
    • Testing Instructions:
      1. Open the course, enable editing
      2. Take the section before the last one and try moving it down far below the last one (the ghost section will be displayed as the last one)
      3. Release the mouse button and observe that the section order has been updated (drop has been processed as if you dropped normally right over the target section)
        (see video in description for example)
      Show
      Open the course, enable editing Take the section before the last one and try moving it down far below the last one (the ghost section will be displayed as the last one) Release the mouse button and observe that the section order has been updated (drop has been processed as if you dropped normally right over the target section) (see video in description for example)
    • Affected Branches:
      MOODLE_23_STABLE
    • Fixed Branches:
      MOODLE_23_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      MDL-32752-master-1

      Description

      If the dragged element is moved a bit further toward the area that has no drop target and dropped, the drop_hit will not be fired, the layout will be corrupted and after page refresh the page will look as initially.

      Bug demo: http://www.youtube.com/watch?v=z6h5MVlmRts&feature=youtu.be

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              salvetore Michael de Raadt added a comment -

              That happens in the Men's room around here.

              kabalin Ruslan Kabalin added a comment -

              Andrew, will you have chance to review it?

              poltawski Dan Poltawski added a comment -

              Looks good to me, thanks Ruslan!

              stronk7 Eloy Lafuente (stronk7) added a comment -

              The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

              TIA and ciao

              kabalin Ruslan Kabalin added a comment -

              Made the integrator life easier (this week only).

              samhemelryk Sam Hemelryk added a comment -

              Thanks guys has been integrated now

              samhemelryk Sam Hemelryk added a comment -

              Tested during integration review and passed

              poltawski Dan Poltawski added a comment -

              Congratulations!

              Your work has made into the latest Moodle release!

              You are only authorised to celebrate after testing 15 Moodle 2.3 QA tests, thanks!

              marina Marina Glancy added a comment -

              It seems that this issue is the cause of MDL-34209 with 106 votes


                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  1 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    25/Jun/12