Moodle
  1. Moodle
  2. MDL-32784

Marking guide advanced grading form type - follow on

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.3
    • Fix Version/s: None
    • Component/s: Grading methods
    • Labels:
    • Affected Branches:
      MOODLE_23_STABLE
    • Rank:
      39785

      Description

      This issue is for follow on issues found from MDL-31731

      Testing also needs to be completed according to: http://lightwork.massey.ac.nz/attachments/1535/TestPlan_MarkingGuide_1_02.docx

        Issue Links

          Activity

          Dan Poltawski created issue -
          Dan Poltawski made changes -
          Field Original Value New Value
          Assignee Marina Glancy [ marina ] Dan Marsden [ danmarsden ]
          Dan Poltawski made changes -
          Link This issue discovered while testing MDL-31731 [ MDL-31731 ]
          Dan Poltawski made changes -
          Tester phalacee
          Jason Fowler added a comment -

          What exactly needs to be done here?

          Dan Marsden added a comment -

          I guess you need to continue testing from where you finished last - and post any further issues you find?

          Dan Poltawski added a comment -

          Yes, please. Ideally we wouldn't have released the new build without completing this testing.

          Jason Fowler added a comment -

          Not waiting for the issues I have already reported to be fixed then?

          Dan Marsden added a comment -

          the ones related to the marking guide should be fixed already - I opened a new one for the new assignment one you found. see MDL-32781

          Jason Fowler added a comment -

          in that case, the testing can probably wait on QA, if you're happy with that.

          Dan Marsden added a comment -

          I guess that's a question for the integrators - I think they passed it on the basis that the testing would be completed.

          Eloy Lafuente (stronk7) added a comment -

          I think we, integrators, would sleep really well if this is tested now (no matter the same tests end being also QA tests or no, that's beyond our capabilities). We made one exception here, allowing that to land without complete testing, but with the "condition" of testing it completely ASAP.

          Imagine we run the QA in 2 weeks and dependent code is built on top, that will lead to a disaster for sure. So I strongly recommend to test this now and, also, promote it to QA tests, for TimB's consideration.

          Ciao

          Sam Hemelryk added a comment -

          Transitioning this through to the testing phase as requested by Jason.

          Sam Hemelryk made changes -
          Status Open [ 1 ] Waiting for integration review [ 10010 ]
          Sam Hemelryk added a comment -

          Moving into current integration so it appears on our lists

          Sam Hemelryk made changes -
          Status Waiting for integration review [ 10010 ] Integration review in progress [ 10004 ]
          Currently in integration Yes [ 10041 ]
          Sam Hemelryk added a comment -

          Ready for testing!

          Sam Hemelryk made changes -
          Status Integration review in progress [ 10004 ] Waiting for testing [ 10005 ]
          Dan Poltawski added a comment -

          Setting myself as integrator since I integrated the other fixes (and this is showing in my search as 'needing integration' )

          Dan Poltawski made changes -
          Integrator poltawski
          Jason Fowler made changes -
          Status Waiting for testing [ 10005 ] Testing in progress [ 10011 ]
          Jason Fowler added a comment -

          I can create a marking guide with a numerical mark, even if the assignment is set to have a non-numerical grading scale.
          To reproduce - create an assignment from the new mod_assign, set the grade to Scale: Satisfactory, and the grading method to Marking Guide. Click Save and Display. Create a Marking Guide and set the maximum on a criterion to 100 and fill in all the other required fields then save it.

          When changing an assignment where grading is already complete from a numerical scale to Scale: Satisfactory, the grades still exist and are editable using the marking guide.

          It would seem that all the places where I have noticed the warnings are missing are due to the fact the testing instructions are not providing a place to actually look for the warnings - they are on the Marking Guide pages, as opposed to the page where the changes are being made on the assignments. Are there hooks in place with in the marking guide that could be called by the assignment module to display warnings when making changes on the assignment page?

          Dan Poltawski added a comment -

          I think that this is likely to be the fault of the mod_assign, interested to hear what Dan has to say about it

          Jason Fowler made changes -
          Status Testing in progress [ 10011 ] Tested [ 10006 ]
          Dan Marsden made changes -
          Description This issue is for follow on issues found from MDL-31731

          Testing also needs to be completed according to: http://lightwork.massey.ac.nz/attachments/1530/TestPlan_MarkingGuide_1_01.docx
          This issue is for follow on issues found from MDL-31731

          Testing also needs to be completed according to: http://lightwork.massey.ac.nz/attachments/1535/TestPlan_MarkingGuide_1_02.docx
          Dan Marsden added a comment -

          really good question!

          The Rubrics grading method doesn't support non-numerical scales either but I suppose someone could write a grading method that did so it's probably not the best idea to prevent the use of advanced grading if non-numerical is set - I wonder if we should implement some form of check to see if a grading method supports non-numerical grades. I'd wonder what Marina thought on this too? (added her as a watcher)

          Marina Glancy added a comment -

          Hi,
          rubrics do support non-numeric scales. Actually all scales are numeric, for example, scale [Bad, Satisfactory, Good] will be converted to [1/3, 2/3, 3/3] when calculating average grade in gradebook. Rubrics act the same. There is a text actually that appears when you edit rubric:

          $string['rubricmappingexplained'] = 'The minimum possible score for this rubric is <b>{$a->minscore} points</b> and it will be converted to the minimum grade available in this module (which is zero unless the scale is used).
          The maximum score <b>{$a->maxscore} points</b> will be converted to the maximum grade.<br />
          Intermediate scores will be converted respectively and rounded to the nearest available grade.<br />
          If a scale is used instead of a grade, the score will be converted to the scale elements as if they were consecutive integers.';

          Michael de Raadt made changes -
          Labels triaged
          Eloy Lafuente (stronk7) added a comment -

          This is now part of Moodle and a few millions people around the globe will be using it soon. Isn't that awesome?

          Many, many thanks and don't forget http://youtu.be/4N7dPaP5Z8U

          Closing, ciao

          Eloy Lafuente (stronk7) made changes -
          Status Tested [ 10006 ] Closed [ 6 ]
          Resolution Fixed [ 1 ]
          Currently in integration Yes [ 10041 ]
          Integration date 11/May/12
          Dan Marsden added a comment -

          thanks Marina - I've just taken another look at the marking guide to verify it operates the same way and handles non-numeric grades as expected and it looks the same to me - thanks.

          Jason - the warnings you mention are soft warnings - it's perfectly valid to create a marking guide with a max mark higher or lower than the max grade set in the assignment but the warning is displayed to make sure the teacher is aware how the grades will be calculated. making these warnings appear when editing the guide could be annoying and confuse some teachers into thinking they were required.

          thanks for the testing and feedback!


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: