Moodle
  1. Moodle
  2. MDL-32794

Scorm Navigation Tree not displaying the entire package

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.1.5, 2.2.2
    • Fix Version/s: 2.1.7, 2.2.4
    • Component/s: SCORM
    • Labels:
    • Testing Instructions:

      Load the SCORM package attached to this tracker issue
      Make sure the setting "Display course structure in player" is set to "To the side"
      Enter the SCORM, click on the top level items in the tree:
      -Lección 1: Estás en Portugal
      --Presentaciones
      -Lección 2: Vida cotidiana
      clicking these items in the tree should cause expand/collapse behaviour but should not trigger a navigation event.
      a navigation event on these items with the old code will cause invalid html to be provded to the treeview.
      In FF this will cause the tree to display a slightly different TOC with a new top level item in the list.
      IE can't cope with the invalid html and a chunk of the treeview items will be hidden.

      NOTE: this is only a partial fix for the issues reported on this bug - any other issues will be dealt with on a separate tracker issue such as MDL-32835

      Show
      Load the SCORM package attached to this tracker issue Make sure the setting "Display course structure in player" is set to "To the side" Enter the SCORM, click on the top level items in the tree: -Lección 1: Estás en Portugal --Presentaciones -Lección 2: Vida cotidiana clicking these items in the tree should cause expand/collapse behaviour but should not trigger a navigation event. a navigation event on these items with the old code will cause invalid html to be provded to the treeview. In FF this will cause the tree to display a slightly different TOC with a new top level item in the list. IE can't cope with the invalid html and a chunk of the treeview items will be hidden. NOTE: this is only a partial fix for the issues reported on this bug - any other issues will be dealt with on a separate tracker issue such as MDL-32835
    • Affected Branches:
      MOODLE_21_STABLE, MOODLE_22_STABLE
    • Fixed Branches:
      MOODLE_21_STABLE, MOODLE_22_STABLE
    • Pull Master Branch:
      master_MDL-32794

      Description

      After Uploading a SCORM package and opening the package. The initial navigation shows all of the files within the scorm package, however once you open a file from the package the navigation at the side of the player does not show all of the files and does not allow you to access any of the files that are not displayed in the players navigation.

      The tree structure is broken up into categories and sub-categories, the first category and its sub-categories are appearing fine, however the second category is appearing as a top-level category instead of as part of the SCORM file and causing further categories to not appear as part of this navigation tree.

      Drop-down menu navigation works as expected and corrects issue (so once navigation stops working, use drop-down to navigate and then functionality is restored).

        Gliffy Diagrams

          Issue Links

            Activity

            Luis Estéfano added a comment -

            Tested using this SCORM 1.2 Multi-Sco package with Moodle 2.2.1 (Build: 20120109) and Moodle 2.2.1+ (Build: 20120213)

            Dan Marsden added a comment -

            Hi Luis,

            seems to be displaying fine for me - can you please paste a few screen-shots of the issue you are experiencing? - do you have any local modifications to your SCORM code? - what browsers have you tested this in?

            Luis Estéfano added a comment -

            Hi Dan,

            Sorry, I tested it with Internet Explorer 8 (another persons experienced the same fail with IE 7). I have done some modifications in the SCORM functions, but I tested it with the standard SCORM code and the result was the same(another persons experimented the same error, so I think is not the code, you can see the links bellow). I attached you two images, with the navigation tree before any interaction and after(we lost the third category and next ones if we have it). Few interactions are needed to broke the navigation tree.

            I think this problems are similar:
            http://tracker.moodle.org/browse/MDL-24728
            http://tracker.moodle.org/browse/MDL-30171

            Greetings

            Luis Estéfano added a comment -

            SCORM_1: Initial State, the complete navigation tree is showed.

            SCORM_2: Next State: the navigation tree is broken from the second category.

            Dan Marsden added a comment -

            Hi Luis, the 2 bugs you link to display quite different behavior than what you are reporting - one I couldn't reproduce and the other is definitely fixed already.

            If you have made local changes to the SCORM code I'd look there first - can you try to reproduce it somewhere like demo.moodle.net ?

            Luis Estéfano added a comment - - edited

            Hi Dan,

            ok, I can reproduce it in demo.moodle.net with Internet Explorer 8.

            I logged in as admin usser and created one SCORM package(with the package attached in this report) in the course CF101 (week 1 May - 7 May). His name is "MDL-32794".

            So the bug appears in Moodle 2.2.2 too.

            If deleted, don't hesitate to contact me and I'll upload it again.

            Greets

            Dan Marsden added a comment -

            hmm - still can't reproduce it? - can you please try to find a list of steps that reliably causes it to occur? - also does it only happen in IE 8 - can you reproduce in FF?

            Dan Marsden added a comment -

            ah - I've managed to reproduce some weird behavior in FF and reproducing it in IE8 - looks quite strange and seems to be related to the items in the navigation that don't have any content

            Dan Marsden added a comment -

            I've tracked it down to an issue with scorm_get_toc when $currentorg = '' which is what happens when someone clicks on those treeview items.

            There are really 2 issues here:

            • Scorm_get_toc really needs a full rewrite to generate valid html for complex trees. (I'll open a new bug for this one)
            • The items in the tree with no content shouldn't be clickable. - this should be addressed on this bug.

            Unfortunately I haven't got a lot of time at the moment so unless this gets a bunch of votes from people affected by the bug (or someone provides funding for my time to sort the issue) it's likely to sit for a bit.

            thanks,

            Dan Marsden added a comment -

            Hi Luis, took a look at this as part of my review of Chris's work on the other bug - am submitting a patch here to prevent the navigation from being triggered on those items in the tree.

            Dan Poltawski added a comment -

            Looks good to me, thanks Dan

            Eloy Lafuente (stronk7) added a comment -

            The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

            TIA and ciao

            Dan Marsden added a comment -

            rebased

            Sam Hemelryk added a comment -

            Thanks Dan, this has been integrated now

            Adrian Greeve added a comment -

            I tested this in Firefox, Chrome, IE8 and Safari. I checked the behaviour pre and post patch to get an idea of the problem. I didn't experience any issues with clicking on the navigation tree with any of the browsers as long as you didn't visit a page (outside the scope of this patch)
            Passing.
            Thanks.

            Eloy Lafuente (stronk7) added a comment -

            U P S T R E A M I Z E D !

            Many thanks for the hard work, closing this as fixed.

            Ciao


              People

              • Votes:
                1 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: