Moodle
  1. Moodle
  2. MDL-32883

Allow teachers to force all incomplete quiz attempts to submit

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Duplicate
    • Affects Version/s: 2.2.2
    • Fix Version/s: None
    • Component/s: Quiz
    • Labels:
      None
    • Affected Branches:
      MOODLE_22_STABLE
    • Rank:
      39952

      Description

      At the moment, I can't find any way that a teacher can force a quiz to end, which happens when students in a class do the questions, and save them, but do not submit what they have done. Could also be used as a forced closure if a teacher is manually monitoring time limits on a quiz. Would think it would be a button on the main quiz page accessible only to teachers that prompts them to submit all open attempts.

      What do you think Tim? Plausible or busted?

        Issue Links

          Activity

          Tim Hunt added a comment -

          Keep up Mark. MDL-3030 has just been Fixed for Moodle 2.3. I think that solves this problem.

          Tim Hunt added a comment -

          Sorry, I mean to resolve this as a duplicate.

          Mark Drechsler added a comment -

          Sorry Tim, I searched for 'force close quiz' and didn't come up with anything that looked like it solved the issue.

          I am not completely sure that MDL3030 does fix the issue either. Yes - I agree that this feature (from the looks of it) allows a quiz to be automatically submitted when the time expires, but does it allow the teacher to force a submission of some or all quiz attempts?

          Use cases I can think of are:
          1. I am invigilating a quiz and I decide that I want to close the quiz right now because I suspect cheating is going on and I want to immediately freeze the responses.
          2. I am invigilating a quiz which is mimicking a real-life scenario in which I will randomly choose to force a submission on my students, or a subset thereof, at my leisure.
          3. I've got several groups of students doing a quiz, and I know one group should have finished all of their responses, and before the next group starts I want to force a submit of that group's responses before the next group starts.

          Can you confirm that these use cases are covered by the 2.3 changes, and without using a time-based method to force the submission event? If so then I am more than happy to have this one closed as a duplicate

          Tim Hunt added a comment -

          3. is covered by the Moodle 2.0 features, where you can have different open and close dates for different students.

          1. You can partly handle by editing the quiz settings to change the close date to Now. This will cause the quiz to submit the next time the student moves to another page, or submits one question.

          2. I just a bit crazy!

          There is a feature that could be implemented, but which has not been yet. In the quiz grades/responses report, you could have an option 'Submit in progress attempts now' next to 'regrade attempts' and 'delete attempts'. Making that button work would be quite easy. The tricky bit would be that if the teacher did that when the student has the quiz open, the next time the student does anything (navigates or submits a question) they will get a fatal error. We would have to detect that situation, and explain what is happening to the student, and I can't quite see how to do that.

          Tim Hunt added a comment -

          And, that last point is also a duplicate: MDL-24814

          Mark Drechsler added a comment -

          So on one hand you're telling me that "there is a feature that could be implemented, but which has not been yet", and at the same time closing the ticket because its a duplicate of tickets relating to existing functionality - correct?

          Tim Hunt added a comment -

          Right, I was not immediately able to to determine whether the scope of what you were requesting was already covered by existing bugs or not.

          You were not capable of finding any of the existing issues that already cover this.

          Clearly neither of us is perfect, but we have both learned something while discussing this. Once we have reached a consensus on what is needed (I think we are close, but not quite there yet) I can reopen the appropriate issue - probably MDL-24814. But that will only happen if we go on discussing this constructively.

          You have not yet commented on the detail of what I proposed in http://tracker.moodle.org/browse/MDL-32883?focusedCommentId=156668&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-156668

          Mark Drechsler added a comment -

          True - neither of us is perfect, but I don't think I ever intimated that on either front - only one of us has the ability to close Tracker tickets though, so I am assuming you are closer to perfection than I am

          My issue is having ideas dismissed in the Tracker, like it appears 24814 was, given that is (from what I can tell) exactly the same thing I requested (i.e. manual forced submission), which you've accepted is not the same as what the quiz now does (i.e. automatic forced submission). I am all for discussing this constructively, I just get slightly disappointed when I get a sense that a "skim it, dismiss it, close it" mentality is applied to suggestions in the Tracker, rather than asking more questions to elicit responses from an end user first. I realise you and the other core developers are all extremely busy, but this is the kind of response that makes it very difficult for me to try and drum up community engagement in the tracker if contributors are going to get shut down as soon as they open their mouths.

          Now, you're right, I didn't respond point by point, I was still clarifying whether there was any validity in my argument. Now it would appear that there may be, so I'll respond one by one:

          "3. is covered by the Moodle 2.0 features, where you can have different open and close dates for different students." <- fair point, and provided I know what times I want the groups to close, then I can forward schedule this. If not, there is at least a workaround to go in and edit the settings to set each group to expire as I need to. I'm thinking there are probably more clicks needed to do it this way, but I accept that there is a work around.

          "1. You can partly handle by editing the quiz settings to change the close date to Now. This will cause the quiz to submit the next time the student moves to another page, or submits one question." <- Again, acknowledged, however again I suspect it will be more clicks than a function like you discuss below, and from an end user's perspective perhaps not so intuitive.

          "2. I just a bit crazy! There is a feature that could be implemented, but which has not been yet. In the quiz grades/responses report, you could have an option 'Submit in progress attempts now' next to 'regrade attempts' and 'delete attempts'. Making that button work would be quite easy. The tricky bit would be that if the teacher did that when the student has the quiz open, the next time the student does anything (navigates or submits a question) they will get a fatal error. We would have to detect that situation, and explain what is happening to the student, and I can't quite see how to do that." <- now we're getting somewhere. This is the kind of function I was thinking of, and the location of the button sounds good to me. Acknowledge that there would be caution needed in how it was implemented and used - are you willing to consider this further?

          Finally, a little background (which perhaps I should have added originally), this was something which was raised to me as one of the most common requests that our Help Desk (supporting numerous Universities running Moodle) receive. The use cases were ones I came up with on the spur of the moment. I will ask them to comment on this ticket directly as to whether we're working towards something of use. As you no doubt also saw I tried to drum up some interest on Twitter for this issue, as I'd love to know if it is just something that our clients ask us for or if it is something on the broader wish-list for larger users.

          Hope this gives some more context and detail,

          Mark.

          Tim Hunt added a comment -

          Right, I reopened MDL-24814 and made you a watcher.

          Given the volume of bug reports I have to triage, the only feasibly option is for me to make snap decisions on most of them. If my first guess is wrong, then people can comment, and we can correct it.


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: