Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-32887

Minify doesn't automatically remove minified files

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Duplicate
    • Affects Version/s: 2.2.2
    • Fix Version/s: None
    • Component/s: Other
    • Labels:
      None
    • Affected Branches:
      MOODLE_22_STABLE

      Description

      Minify is used in Moodle to reduce size of css and javascript files in Moodle 2. It creates temp files in a configurable location. The default location is $CFG->dataroot/cache/, under which Minify will create folders like js etc.

      The problem is these files are never removed even though they passed expiry time.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              skodak Petr Skoda added a comment -

              Hello,
              the caches should be removed during each moodle upgrade or when you manually clear via admin menu. The minify library integration was reworked recently in 2.3dev and it should finally resolve this and other known problems.

              Thanks for the report.


                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  1 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: