Moodle
  1. Moodle
  2. MDL-32915

On Chat GUI-basic there's a DIV not closed

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Affects Version/s: 2.2, 2.2.2
    • Fix Version/s: 2.1.7, 2.2.4
    • Component/s: Chat
    • Labels:
      None
    • Testing Instructions:
      Hide

      1/ create chat
      2/ go to basic chat UI
      3/ run xhtml validation in your browser (you need some tool such as HTML Validator for FF)

      Show
      1/ create chat 2/ go to basic chat UI 3/ run xhtml validation in your browser (you need some tool such as HTML Validator for FF)
    • Workaround:
      Hide

      Erase line 118 of /mod/chat/gui_basic/index.php:
      echo '<div id="">';

      Show
      Erase line 118 of /mod/chat/gui_basic/index.php: echo '<div id="">';
    • Difficulty:
      Easy
    • Affected Branches:
      MOODLE_22_STABLE
    • Fixed Branches:
      MOODLE_21_STABLE, MOODLE_22_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      w20_MDL-32915_m23_chatdiv
    • Rank:
      39995

      Description

      On /mod/chat/gui_basic/index.php

      There's a div not closed that seems to be wrong. It breaks the page.
      On line 118:
      echo '<div id="">';

      I think it can be erased.

        Activity

        Hide
        Petr Škoda added a comment -

        Thanks a lot for the report.

        Show
        Petr Škoda added a comment - Thanks a lot for the report.
        Hide
        Dan Poltawski added a comment -

        Integrated, thanks

        Show
        Dan Poltawski added a comment - Integrated, thanks
        Hide
        Pau Ferrer Ocaña (crazyserver) added a comment -

        A pleasure!

        Show
        Pau Ferrer Ocaña (crazyserver) added a comment - A pleasure!
        Hide
        Adrian Greeve added a comment -

        Tested branches 2.1, 2.2 and master. The xhtml validation no longer comes up with an error for the div tag not being closed, though there is still an error for "tabindex" not being an attribute.
        Thanks.

        Show
        Adrian Greeve added a comment - Tested branches 2.1, 2.2 and master. The xhtml validation no longer comes up with an error for the div tag not being closed, though there is still an error for "tabindex" not being an attribute. Thanks.
        Hide
        Eloy Lafuente (stronk7) added a comment -

        U P S T R E A M I Z E D !

        Many thanks for the hard work, closing this as fixed.

        Ciao

        Show
        Eloy Lafuente (stronk7) added a comment - U P S T R E A M I Z E D ! Many thanks for the hard work, closing this as fixed. Ciao

          People

          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: