Details

    • Type: Task Task
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 2.3
    • Fix Version/s: 2.3
    • Component/s: Assignment
    • Labels:
    • Testing Instructions:
      1. Create an instance of mod_assign in a course.
      2. Make sure that advanced grading is not used and that outcomes are enabled.
      3. View the "View/grade all submissions" page for the new mod_assign instance
      4. Click on the "Quick grading" checkbox in the options form above the list of submissions
      5. All the grades and outcomes should change to editable fields with a "Save all changes" button at the bottom of the table.
      6. As fields are changed the cell they are in should change colour to indicate that there are unsaved changes
      7. If there are unsaved changes, clicking on the pagination links for the table should produce a browser warning about unsaved changes in the page.
      8. Just clicking on the selection checkboxes to select rows in the submissions table should not produce the above browser warning.
      9. Change at least one grade and click "Save all changes" to save all the modified grades and outcomes.
      10. Should see a confirmation screen that confirms all the changes were saved with a continue button.
      11. Use your browser back button to go back to the previous page and click "Save all changes" again.
      12. You should see an error message that says "The grades were not saved because someone has modified one or more records more recently than when you loaded the page."
      13. Edit the settings for the assign instance and enable advanced grading (choose an active grading form)
      14. View the "View/grade all submissions" page for the new mod_assign instance
      15. There should be no option to enable quick grading
      Show
      Create an instance of mod_assign in a course. Make sure that advanced grading is not used and that outcomes are enabled. View the "View/grade all submissions" page for the new mod_assign instance Click on the "Quick grading" checkbox in the options form above the list of submissions All the grades and outcomes should change to editable fields with a "Save all changes" button at the bottom of the table. As fields are changed the cell they are in should change colour to indicate that there are unsaved changes If there are unsaved changes, clicking on the pagination links for the table should produce a browser warning about unsaved changes in the page. Just clicking on the selection checkboxes to select rows in the submissions table should not produce the above browser warning. Change at least one grade and click "Save all changes" to save all the modified grades and outcomes. Should see a confirmation screen that confirms all the changes were saved with a continue button. Use your browser back button to go back to the previous page and click "Save all changes" again. You should see an error message that says "The grades were not saved because someone has modified one or more records more recently than when you loaded the page." Edit the settings for the assign instance and enable advanced grading (choose an active grading form) View the "View/grade all submissions" page for the new mod_assign instance There should be no option to enable quick grading
    • Affected Branches:
      MOODLE_23_STABLE
    • Fixed Branches:
      MOODLE_23_STABLE
    • Pull Master Branch:
    • Rank:
      40011

      Description

      It seems that the quick grading option is no longer available in the assignments, which was available in 2.2

        Issue Links

          Activity

          Michael de Raadt added a comment -

          Thanks for pointing this out, Gavin.

          If the new assignment module is to reflect the same functionality as the old assignment module, this should be added. Instructors will miss this.

          Damyon Wiese added a comment -

          I looked really hard at this and found a number of problems.

          1. The solution for the old assignment module is a constant source of complaints about markers overwriting each others grades (2 markers open the quickgrading form at the same time, spend ages entering marks, hit save - last one wins.

          2. I tried a YUI popup for the grading page that refreshed the table row in the background and this was much better - the problem is that the currently in Moodle it is impossible to put elements in a popup that have javascript dependencies (like advanced grading/file picker etc). There is an experimental branch with this feature in my github.

          3. Quickgrading in 2.2 does not work with rubrics file uploads, disregards editor format for feedback, more...

          Any suggestions?

          gavin henrick added a comment -

          regarding #1 rather than changing the initial migration version which I thought was to be a clone of the existing features, would this not best be solved in later iterations with discussed options through forums for a specification of assigning people to mark certani people or as you mention a popup for it?

          so, although it may not be perfect, but as the feature is there perhaps best to keep it initially to avoid a usability regression while moving from 4 to 1.

          oh, and it does work with outcomes in the normal assignment 2.x - image attached.

          gavin henrick added a comment -

          The outcomes in quick grading.

          Ray Lawrence added a comment -

          Agreed. This is a big area of functionality to drop at this stage, even if it's not perfect.

          Ray Lawrence added a comment -
          1. 3 Is there a tracker issue for this that we can vote for?
          Lesli Smith added a comment -

          Thanks for pointing us here, Damyon. Um, I guess when I was playing with assignment in Moodle 2.2 and quick grading became unavailable to me when I turned on rubrics, that made sense to me. If I am using a rubric, I should be forced to look at each rubric individually. The real uproar with teachers will be if there is not a choice to have a really quick assignment grade that doesn't need a rubric. When you are teaching 100+ students, and the assignment is a pretty simple one, quick-grading is a big timesaver/lifesaver. Sooo, to me it is okay if quick grading is only available in the one grading mode. I hope that makes sense.

          Lesli Smith added a comment -

          If quick-grading is not working with outcomes, that is a much bigger deal (or if outcomes aren't showing up at all). Please point us where we need to go if that gets added to the tracker as a separate issue. Thanks.

          gavin henrick added a comment -

          As shown in attached, in normal 2.2 assignments quickgrading does work with outcomes.

          Michael Woods added a comment -

          Agree with Lesli. I'm fine for quick grading to not be available with rubric and other advanced grading methods, but it's a big regression to no longer have it for standard (direct) grading.

          Martin Dougiamas added a comment -

          Yep, quick grading needs to be there when simple grades are enabled. In 2.3. If all we have time for is the whole-page form then so be it - it's not worse than 2.2.

          The "proper" solution probably involves more AJAX so that teachers can see other teachers updating rows in real time. I can see that would take a lot longer.

          Damyon Wiese added a comment -

          OK - I'll re-implement the old version of quickgrading and we can try and improve it in the future.

          • Damyon
          Damyon Wiese added a comment -

          MDL-32933 implements outcomes. Quickgrading includes support for outcomes - so this patch is based on the weekly Moodle 2.3 dev branch with the patch for MDL-32933 cherry-picked on top.

          Dan Poltawski added a comment -

          Bringing this into integration, since I assume its an essential 2.3 feature.

          Eloy Lafuente (stronk7) added a comment -

          The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

          TIA and ciao

          Dan Poltawski added a comment -

          Hi Damyon,

          This appears to be conflicting with the outcomes work in master slightly. Are you able to fix that conflict?

          Sam Hemelryk added a comment -

          Looks like this needs to land, looking at it now.

          Damyon Wiese added a comment -

          Sorry - I didn't get to this yesterday - let me know if you want me to rebase it/sort out the conflict with outcomes.

          Sam Hemelryk added a comment -

          Hi Damyon,

          No probs about the conflict, I think I can get that sorted no probs.

          However there is one blocker I've hit to this issue presently, if the assignment is using a normal grade (out of 100 for instance) then quick grading doesn't work.
          It appears that display_grade only adds the grademodified_xx input for scales, and process_save_quick_grades is relying on that field in its checking: https://github.com/netspotau/moodle-mod_assign/commit/bf78ebd650779231fc16bb0c50c9e2d80fd47bc9#L4R2339

          I've found a couple of other bugs and have a patch that will get integrated if this gets accepted, however I need to know the solution to the above problem first.
          Do we need to add the grademodified column to the standard (non-scale) code when editing like we do for scales?
          (Apologies if I've missed something here)

          Cheers
          Sam

          Michael Woods added a comment -

          I've just created MDL-33168, which highlights a bug in quickgrading in the 1.9 and 2.2 branches. It would be great if it could be considered in the implementation of 2.3, so that the same bug is not across 3 moodle versions.

          Damyon Wiese added a comment -

          Hi Sam,

          Yes the grademodified hidden input should be added to the display_grade function for normal numerical grades. Sorry about the bug. You can add:

          $o .= '<input type="hidden" name="grademodified_' . $userid . '" value="' . $modified . '"/>';

          At line 903 to fix this.

          I'll rebase and push to a new branch with the fix.

          Regards, Damyon

          Sam Hemelryk added a comment -

          Hi Damyon,
          Thanks for the speedy reply, I was hoping you would be online.
          I've made the change now and it fixes the issue perfectly thanks.

          Cheers
          Sam

          Sam Hemelryk added a comment -

          Ok this has been integrated now thanks Damyon.

          I tested during integration but given I found and fixed a couple of issues I think it is best that someone else tests this as well.

          Also the use of $_POST here is pretty scary. I let this in as we need this feature for 2.3 and that is what the original assignment is doing however I did make a couple of changes to ensure that things we as we expected and that they were cleaned. We still however at some point need to use a proper lookup. Collect all of the people from the report and iterate them looking for changes rather than iterating post.

          Cheers
          Sam

          Jason Fowler added a comment -

          Worked fine for me

          Eloy Lafuente (stronk7) added a comment -

          This issue has been integrated upstream and is now available both via git and cvs (and in some hours, via mirrors and downloads).

          Thanks!

          Lesli Smith added a comment -

          Hi. Could someone tell me if this is applied on the QA site yet? I was working on http://tracker.moodle.org/browse/MDLQA-1873 and found that feedback was not working for an "offline" type assignment in quick grade. (Or maybe I'm not following correctly and only the grade part for quick grade is what is supposed to be working so far?) Either way, please let us know if we are seeing what we should be seeing on the QA site so far. Thanks!

          Michael de Raadt added a comment -

          Hi, Lesli.

          It looks like it should have been. The change should have been made available last night before your ran the test. I will check my local test server.

          Michael de Raadt added a comment -

          It looks like it is not possible to add feedback with quick grading. Is this correct, Damyon?

          Damyon Wiese added a comment -

          Sorry for the delay in responding. Yes it is not currently possible. I can add support for it - but it will require some nasty quickgrading specific support in the plugins - I will be able to look at doing this tomorrow. (I'll make a separate ticket for it).

          Regards, Damyon

          Thomas Bachert added a comment -

          Please add the option for the assignment's Quick Grading feature to open in a popup window as it was in 1.9? Teachers were able to enter the assignment, choose a class/group, click on a student's submission, and then the submission would open in a new window. Now, the submission instead opens in the same window, which takes the teacher back to the top of the class/group list rather than directly to the student the teacher is trying to grade.

          Thank you for all you time - Tom

          Ray Lawrence added a comment -

          I don't remember quick grading opening in a pop-up.


            People

            • Votes:
              23 Vote for this issue
              Watchers:
              13 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: