Moodle
  1. Moodle
  2. MDL-33042

Assign: email_graders function name is too specific

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.3
    • Fix Version/s: 2.3
    • Component/s: Assignment
    • Labels:
      None
    • Testing Instructions:
      Hide
      1. Create assignment in the course with existing teacher (with grading permission), enable 'Notify graders about submissions'. Make sure that 'assignment grader notification' is enabled in messaging preferences.
      2. As student, make sure that email notification for assignment is enabled and submit the assignment.
      3. Make sure that both student and teacher received email notifications.
      Show
      Create assignment in the course with existing teacher (with grading permission), enable 'Notify graders about submissions'. Make sure that 'assignment grader notification' is enabled in messaging preferences. As student, make sure that email notification for assignment is enabled and submit the assignment. Make sure that both student and teacher received email notifications.
    • Affected Branches:
      MOODLE_23_STABLE
    • Fixed Branches:
      MOODLE_23_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      MDL-33042-master-1
    • Rank:
      40219

      Description

      Since 2.1 message_send(); is using all existing message processors, not email only. For the new assignment module I think email_graders() should be renamed to something less specific.

        Issue Links

          Activity

          Hide
          Ruslan Kabalin added a comment - - edited

          Added Damyon to watchers.

          Would be good to have this applied while we are not too far.

          Show
          Ruslan Kabalin added a comment - - edited Added Damyon to watchers. Would be good to have this applied while we are not too far.
          Hide
          Damyon Wiese added a comment -

          Hi Ruslan,

          No problem with the renaming - but this might be better done after MDL-31414 is integrated as it touches most of the messaging functions.

          http://tracker.moodle.org/browse/MDL-31414

          Regards, Damyon

          Show
          Damyon Wiese added a comment - Hi Ruslan, No problem with the renaming - but this might be better done after MDL-31414 is integrated as it touches most of the messaging functions. http://tracker.moodle.org/browse/MDL-31414 Regards, Damyon
          Hide
          Ruslan Kabalin added a comment -

          Ah, OK, did not spot MDL-31414. Then I will make this dependant on MDL-31414 and adjust again after MDL-31414 is integrated.

          Show
          Ruslan Kabalin added a comment - Ah, OK, did not spot MDL-31414 . Then I will make this dependant on MDL-31414 and adjust again after MDL-31414 is integrated.
          Hide
          Ruslan Kabalin added a comment -

          Ready for review now.

          Show
          Ruslan Kabalin added a comment - Ready for review now.
          Hide
          Andrew Davis added a comment -

          Simple enough change. Just add some testing instructions to make sure its all working as before and put it up for integration

          Show
          Andrew Davis added a comment - Simple enough change. Just add some testing instructions to make sure its all working as before and put it up for integration
          Hide
          Ruslan Kabalin added a comment -

          Thanks Andrew, instructions are added.

          Show
          Ruslan Kabalin added a comment - Thanks Andrew, instructions are added.
          Hide
          Dan Poltawski added a comment -

          The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

          TIA and ciao

          Show
          Dan Poltawski added a comment - The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week. TIA and ciao
          Hide
          Dan Poltawski added a comment -

          Thinks makes sense and I've integrated this now (noting that Damyon has OK'ed the change).

          Thanks everyone.

          Show
          Dan Poltawski added a comment - Thinks makes sense and I've integrated this now (noting that Damyon has OK'ed the change). Thanks everyone.
          Hide
          Eloy Lafuente (stronk7) added a comment -

          We could celebrate it today... but better if we perform a bigger party after releasing Moodle 2.3.

          Print this message and come to Perth that day, it's valid for one beer, wine, coke or... water, as you wish.

          Many thanks for your collaboration!

          Ciao

          Show
          Eloy Lafuente (stronk7) added a comment - We could celebrate it today... but better if we perform a bigger party after releasing Moodle 2.3. Print this message and come to Perth that day, it's valid for one beer, wine, coke or... water, as you wish. Many thanks for your collaboration! Ciao

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: