Moodle
  1. Moodle
  2. MDL-33073

Toolbox doesn't work with newly drag/dropped items in course page

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.3
    • Fix Version/s: 2.3
    • Component/s: Course
    • Labels:
    • Testing Instructions:

      These tests check that the new drag/drop toolboxes work correctly:

      • Open a course page
      • Drag and drop a new file in place
      • try each of the AJAX functions to ensure that they work:
        • indent right
        • indent left
        • show
        • hide
        • delete

      These tests check for regressions of the fix in MDL-32745 and should be completed with the javascript console open to check for errors.

      • Open the Site Front Page and turn editing on
      • In the central resource area:
      • Create a couple of activities including:
        • a label
        • an activity
        • another resource
      • try each of the AJAX functions to ensure that they work:
        • indent right
        • indent left
        • show
        • hide
        • group mode toggle (on the activity)
        • delete
      • If you don't already have it, add a 'Main Menu' block on the site front page
      • Create a couple of activities including:
        • a label
        • an activity
        • another resource
      • try each of the function icons – they should cause page reloads now:
        • show
        • hide
        • group mode toggle (on the activity)
        • delete
      • Open a course page and turn editing on
      • In the first topic/week area:
      • Create a couple of activities including:
        • a label
        • an activity
        • another resource
      • try each of the AJAX functions to ensure that they work:
        • indent right
        • indent left
        • show
        • hide
        • group mode toggle (on the activity)
        • delete
        • toggle the section/week visibility
      Show
      These tests check that the new drag/drop toolboxes work correctly: Open a course page Drag and drop a new file in place try each of the AJAX functions to ensure that they work: indent right indent left show hide delete These tests check for regressions of the fix in MDL-32745 and should be completed with the javascript console open to check for errors. Open the Site Front Page and turn editing on In the central resource area: Create a couple of activities including: a label an activity another resource try each of the AJAX functions to ensure that they work: indent right indent left show hide group mode toggle (on the activity) delete If you don't already have it, add a 'Main Menu' block on the site front page Create a couple of activities including: a label an activity another resource try each of the function icons – they should cause page reloads now: show hide group mode toggle (on the activity) delete Open a course page and turn editing on In the first topic/week area: Create a couple of activities including: a label an activity another resource try each of the AJAX functions to ensure that they work: indent right indent left show hide group mode toggle (on the activity) delete toggle the section/week visibility
    • Difficulty:
      Easy
    • Affected Branches:
      MOODLE_23_STABLE
    • Fixed Branches:
      MOODLE_23_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      MDL-33073-master-1
    • Rank:
      40288

      Description

      Just been playing around with the drag drop and I noticed a bug in the toolbox code. This is a regression caused by MDL-32745 being too specific now

        Issue Links

          Activity

          Andrew Nicols added a comment -

          Adding you as a watcher Dan as you integrated both of these.

          Dan Poltawski added a comment -

          argh. you've duplicated another issue

          Dan Poltawski added a comment -

          Is this not the same issue as MDL-33062 (which I created first!)

          Andrew Nicols added a comment -

          gah - it is, but I hadn't seen the mail for that yet!

          Dan Poltawski added a comment -

          Integrated this, thanks

          Adrian Greeve added a comment - - edited

          I tested this out in Firefox, Internet Explorer, Chrome and Safari.
          A few comments:
          Main menu block

          1. hiding a label doesn't change the text colour to grey (or a darker colour. The label is still hidden)
          2. There is no icon for changing the group mode of the activity.

          Course

          1. Moving a section / week around generates the following error:
            sectionlist.item(node1).one("." + CSS.WEEKDATES) is null
            These may not be relevant to this fix, but I thought that I'd mention them anyway.
            Thanks.
          Eloy Lafuente (stronk7) added a comment -

          U P S T R E A M I Z E D !

          Many thanks for the hard work, closing this as fixed.

          Ciao

          Tim Barker added a comment -

          Adrian has added the QA tests for this already so removed teh QA tests requd flag.


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: