Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-32999 META: Files UI Stage 2 polishing in master
  3. MDL-33127

Adding two files from different sources to a filearea can get them confused

    Details

    • Type: Sub-task
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.3
    • Fix Version/s: 2.3
    • Component/s: Files API
    • Labels:
      None

      Description

      How to reproduce:

      1) Add a file A to private files and save.
      2) Make a folder F in a course, and edit files
      3) Add a link A2 to the file A, in folder F
      4) Add a file B from wikimedia to the folder F (it is copied)
      5) Save the filearea F and reopen
      6) The wikimedia file has been replaced by a second copy of A2 (except the name).

        Gliffy Diagrams

          Attachments

            Activity

            dougiamas Martin Dougiamas added a comment -

            As I demoed to you.

            dongsheng Dongsheng Cai added a comment - - edited

            Fixed it, it's the patch added this morning trying to improve the mimetype.

            commit: 423dd5b

            marina Marina Glancy added a comment -

            done

            dougiamas Martin Dougiamas added a comment -

            Thanks! Closing as this will be integrated with the big branch shortly.

            dougiamas Martin Dougiamas added a comment -

            I'm still seeing this in integration.git

            dongsheng Dongsheng Cai added a comment - - edited

            Martin, I cannot reproduce this my branch (I could reproduce it before this patch)

            poltawski Dan Poltawski added a comment -

            Is this a bug or not? If so please could we have better testing instructions than 'Another fix, please review.' - is it as the same replication instructions as in the bug summary?

            dongsheng Dongsheng Cai added a comment -

            It's the same bug summary, that's another bug causing the same problem

            dougiamas Martin Dougiamas added a comment -

            it is still happening for me, with exactly the same instructions.

            dongsheng Dongsheng Cai added a comment -

            Martin, this haven't been integrated yet.

            marina Marina Glancy added a comment -

            Dongsheng, your commit mentioned above was integrated
            https://github.com/moodle/moodle/commit/70c1bc843a2d989ea29301bef45bc92cc25773e7

            or do you have something else?

            dougiamas Martin Dougiamas added a comment -

            Aha, inside the loops. That looks like it.

            poltawski Dan Poltawski added a comment -

            Integrated, thanks

            poltawski Dan Poltawski added a comment -

            (would've been great to have unit test for this)

            abgreeve Adrian Greeve added a comment -

            I managed to replicate this on my pre-patch copy of master. The integration version no longer has this issue. I didn't encounter any problems.
            Test passed
            Thanks.

            stronk7 Eloy Lafuente (stronk7) added a comment -

            This issue has been integrated upstream and is now available both via git and cvs (and in some hours, via mirrors and downloads).

            Thanks!


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  25/Jun/12