Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-33146

Section drag and drop causes javascript error in weekly format

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.3
    • Fix Version/s: 2.3
    • Component/s: Course
    • Labels:

      Description

      This is from MDLQA-2134

      Section drag and drop fails due to javascript error:

      Webpage error details
       
      User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E)
      Timestamp: Mon, 21 May 2012 13:39:20 UTC
       
       
      Message: extend failed, verify dependencies
      Line: 43
      Char: 210
      Code: 0
      URI: http://qa.moodle.net/theme/yui_combo.php/3.5.1/build/yui/yui.js
       

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              salvetore Michael de Raadt added a comment -

              We were able to find a JS error when shifting weeks. This appeared to happen across browsers. The error reported by Firebug was...

              sectionlist.item(node1).one("." + CSS.WEEKDATES) is null
              http://localhost/moodle_testing/course/format/weeks/format.js
              Line 50

              We're still following up on the original report.

              rajeshtaneja Rajesh Taneja added a comment - - edited
              rajeshtaneja Rajesh Taneja added a comment -

              This will be fixed properly by MDL-32824

              salvetore Michael de Raadt added a comment -

              The original error appears to have been caused by some over-zealous filtering.

              As people are working on MDL-32824, which will specifically resolve the section title issue, I believe this issue can be closed.

              salvetore Michael de Raadt added a comment -

              It looks like we have a solution to this specific part of the problem. I am reopening this issue so we can push this through.

              Sorry for the miscommunication.

              rajeshtaneja Rajesh Taneja added a comment -

              Thanks Adrian,

              Looks good to me.

              poltawski Dan Poltawski added a comment -

              Thanks for this - i've integrated it now

              poltawski Dan Poltawski added a comment -

              Passing test to be completed in QA

              stronk7 Eloy Lafuente (stronk7) added a comment -

              This issue has been integrated upstream and is now available both via git and cvs (and in some hours, via mirrors and downloads).

              Thanks!


                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  0 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    25/Jun/12