Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-32999 META: Files UI Stage 2 polishing in master
  3. MDL-33152

Move submit buttons more towards the center of the page (not hard left)

    Details

    • Type: Sub-task
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.2
    • Fix Version/s: 2.3
    • Component/s: Filepicker
    • Labels:
      None
    • Testing Instructions:

      Before testing please view the image below to become acquainted with how the form looked before.

      1. Log in as the administrator
      2. Navigate to [Navigation->My Home]
      3. Click 'Manage my private files' in the My private files block. (Add the block if it is not present)

      [Test] The 'Save changes' and 'Cancel' buttons should be aligned with the other buttons and upload area of the form.

      Please test other forms and also different themes.

      Show
      Before testing please view the image below to become acquainted with how the form looked before. Log in as the administrator Navigate to [Navigation->My Home] Click 'Manage my private files' in the My private files block. (Add the block if it is not present) [Test] The 'Save changes' and 'Cancel' buttons should be aligned with the other buttons and upload area of the form. Please test other forms and also different themes.
    • Affected Branches:
      MOODLE_22_STABLE
    • Fixed Branches:
      MOODLE_23_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      wip-MDL-33152-master

      Description

      It's been like this since 2.0, but I hate it. The buttons are by default way off to the left.

      At least for things like Private Files and editing a Folder: let's center them.

        Gliffy Diagrams

          Attachments

            Activity

            marina Marina Glancy added a comment -

            since it really has nothing to do with files usability changes, this is pure Forms API, can somebody else (maybe from STABLE team) take care of it?

            dougiamas Martin Dougiamas added a comment -

            Well, I was only requesting it for those two pages.

            While I think we COULD do it for all forms that might cause more than a few regressions also ... try it out though Adrian.

            dougiamas Martin Dougiamas added a comment -

            +1 for the 15% margin you just showed me across all forms!

            abgreeve Adrian Greeve added a comment -

            This is a fairly simple change to the theme/base/style/core.css file and should effect all Moodle forms. I've tried this with a few different themes and they all seem to behave the same way.

            I've changed the margin width to 15% as Martin mentioned. (Thank you for looking that over for me)

            dougiamas Martin Dougiamas added a comment -

            Dan this should be fairly non-contentious (I thought it had landed already on Tuesday actually!)

            poltawski Dan Poltawski added a comment -

            Integrated, thanks. Who knows that the widespread implications of this 15% will be!

            dougiamas Martin Dougiamas added a comment -

            I tested lots of forms all over as well as couple of different themes and it only looks better to me!

            stronk7 Eloy Lafuente (stronk7) added a comment -

            This issue has been integrated upstream and is now available both via git and cvs (and in some hours, via mirrors and downloads).

            Thanks!

            dougiamas Martin Dougiamas added a comment - - edited

            D'oh! Forgot to do canvas themes! (eg try NonZero theme) See MDL-33931


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  25/Jun/12