Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-32999 META: Files UI Stage 2 polishing in master
  3. MDL-33156

16px icons need some custom love to make them fit better with others

    Details

    • Type: Sub-task
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.3
    • Fix Version/s: 2.3
    • Component/s: Filepicker
    • Labels:
      None

      Description

      The 16px file icons need some love to make them more recognisable and to make them fit in with the other icons on the course page and elsewhere.

      I suggest:

      1) The generic image icon should not be a document (at any size, really). Make it a generic photo with a border, something like http://www.iconfinder.com/icondetails/7366/128/image_photo_style_icon

      2) If the icon is a document with a shape in the middle, then throw away the document border and just make the center shape 16x16. So less like http://www.iconfinder.com/icondetails/47975/128/audio_file_icon and more like http://www.iconfinder.com/icondetails/42341/48/high_sound_speaker_volume_icon , for example.

      3) Tweak the image manually to make it crisper on screen.

        Gliffy Diagrams

          Attachments

            Activity

            barbararamiro Barbara Ramiro added a comment -

            Martin, please let me know what you think of these 16x icons

            dougiamas Martin Dougiamas added a comment -

            Much better!

            Suggested improvements:

            • zip just looks like a streak. How about a little 3D box for all such archive formats?
            • avi/mov/wmv/mpeg - I would make them all similar "film strip" icons, perhaps in diff colours matching bigger icons.
            • wav/wma/mp3 - Make them all "speaker" icons like wma, but diff colours matching the bigger icons.
            dougiamas Martin Dougiamas added a comment -

            Looks much better than before! We can always tweak endlessly but my +10 to integrate this now!

            poltawski Dan Poltawski added a comment -

            Integrated, thanks

            poltawski Dan Poltawski added a comment -

            Assigning to Martin to test

            poltawski Dan Poltawski added a comment -

            Martin, i've pulled in your icon changes. Please can you confirm this is good now?

            dougiamas Martin Dougiamas added a comment -

            It's certainly better IMO.

            Looking forward to more tweaks on all icons in 2.4.

            stronk7 Eloy Lafuente (stronk7) added a comment -

            Big thanks for the effort. This is now part of Moodle upstream. Let's wait for regressions, yay! LOL

            Ciao


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  25/Jun/12