Moodle
  1. Moodle
  2. MDL-33173

Remove unnecessary file user/files.php

    Details

    • Type: Task Task
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.3
    • Fix Version/s: 2.3
    • Component/s: Filepicker
    • Labels:
      None
    • Rank:
      41049

      Description

      Remove the file user/files.php as we do not need it anymore because of MDL-32981.

        Issue Links

          Activity

          Hide
          Frédéric Massart added a comment -

          Instead of removing the page, I renamed filesedit.php to files.php

          Show
          Frédéric Massart added a comment - Instead of removing the page, I renamed filesedit.php to files.php
          Hide
          Sam Hemelryk added a comment -

          Hi Fred,

          It makes sense to me to use files instead of filesedit.
          However can you do two things before this gets put up for integration:

          1. Check with Marina that this isn't going to cause conflict/greif with her work on files.
          2. Pull in the latest master and rebase this change. It conflicts at the moment, likely because someone has modified filesedit and git is currently tracking it as being remove and not having been renamed.

          Cheers
          Sam

          Show
          Sam Hemelryk added a comment - Hi Fred, It makes sense to me to use files instead of filesedit. However can you do two things before this gets put up for integration: Check with Marina that this isn't going to cause conflict/greif with her work on files. Pull in the latest master and rebase this change. It conflicts at the moment, likely because someone has modified filesedit and git is currently tracking it as being remove and not having been renamed. Cheers Sam
          Hide
          Marina Glancy added a comment -

          I don't think it should create any conflicts

          Show
          Marina Glancy added a comment - I don't think it should create any conflicts
          Hide
          Frédéric Massart added a comment -

          Resubmitting for peer review.

          Show
          Frédéric Massart added a comment - Resubmitting for peer review.
          Hide
          Sam Hemelryk added a comment -

          Cool all looks good Fred. One more thing occured to me however, we should probably rename filesedit_form.php to files_form.php.
          Our naming convention when using mforms is typically filename.php + filename_form.php.
          Once done feel free to put this straight up for integration

          Cheers
          Sam

          Show
          Sam Hemelryk added a comment - Cool all looks good Fred. One more thing occured to me however, we should probably rename filesedit_form.php to files_form.php. Our naming convention when using mforms is typically filename.php + filename_form.php. Once done feel free to put this straight up for integration Cheers Sam
          Hide
          Frédéric Massart added a comment -

          Changes reflected. Pushing for integration.

          Show
          Frédéric Massart added a comment - Changes reflected. Pushing for integration.
          Hide
          Dan Poltawski added a comment -

          Hi Fred,

          Thanks I have integrated this now. I made one tiny correction to the phpdoc. You changed the @package name to moodle - I don't think that was matching our styles, so I made it into core_files:
          "If the file is part of a core subsystem then it will be core_xxxx where xxxx is the name defined in get_core_subsystems(). (eg core_enrol or core_group)"
          http://docs.moodle.org/dev/Coding_style#.40package

          Show
          Dan Poltawski added a comment - Hi Fred, Thanks I have integrated this now. I made one tiny correction to the phpdoc. You changed the @package name to moodle - I don't think that was matching our styles, so I made it into core_files: "If the file is part of a core subsystem then it will be core_xxxx where xxxx is the name defined in get_core_subsystems(). (eg core_enrol or core_group)" http://docs.moodle.org/dev/Coding_style#.40package
          Hide
          Frédéric Massart added a comment -

          Hi Dan,

          Thanks for editing while integrating. I actually did not change it manually, the package name was the one in filesedit.php which has been renamed to files.php. Anyway, that's good to know about that package conventions, thanks!

          Show
          Frédéric Massart added a comment - Hi Dan, Thanks for editing while integrating. I actually did not change it manually, the package name was the one in filesedit.php which has been renamed to files.php. Anyway, that's good to know about that package conventions, thanks!
          Hide
          Dan Poltawski added a comment -

          Ahha, ha (yes our existing phpdoc is mostly very inconsistent!) thanks

          Show
          Dan Poltawski added a comment - Ahha, ha (yes our existing phpdoc is mostly very inconsistent!) thanks
          Hide
          Ankit Agarwal added a comment -

          works as expected.
          Passing
          Thanks

          Show
          Ankit Agarwal added a comment - works as expected. Passing Thanks
          Hide
          Eloy Lafuente (stronk7) added a comment -

          This issue has been integrated upstream and is now available both via git and cvs (and in some hours, via mirrors and downloads).

          Thanks!

          Show
          Eloy Lafuente (stronk7) added a comment - This issue has been integrated upstream and is now available both via git and cvs (and in some hours, via mirrors and downloads). Thanks!

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: