Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-33204

Export as IMS/Import as HTML of Book content shuffles chapters, requiring manual re-sorting

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.1.1
    • Fix Version/s: 2.3
    • Component/s: Book
    • Labels:
      None

      Description

      To migrate/duplicate some Moodle Book content we have been "Exporting to IMS" from the source Book and the using the "Import as HTML" feature in the destination Book. This has been particularly useful for migrating from 1.9 to 2.X, as this process seems to keep all the images and links intact.

      The process works well with one exception. On importing the content, the chapters are added out-of-order and have to be manually and individually moved back into the correct place.

      Perhaps this is because the export creates numerically ordered folders, but the import reads them in alphabetical order? So an 11 chapter book gets ordered as 1,10,11,2,3... Not sure if this is the exact issue, just an idea.

      It would save a lot of manual work and make the export/import more elegant if chapter ordering was preserved. Thanks

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              skodak Petr Skoda added a comment -

              Hello,

              yes, this is caused by the fact the html import sorts directories alphabetically. I am sorry I am not going to maintain Book module in the future. It is however still possible that this module will be part of some future Moodle versions.

              Petr

              skodak Petr Skoda added a comment -

              thanks for the report.

              stronk7 Eloy Lafuente (stronk7) added a comment - - edited

              Integrated, thanks!

              Side note: I think you can easily dupe/import activities (books) from within Moodle without needing to export as ims-cc & import later.

              abgreeve Adrian Greeve added a comment -

              Check this out pre and post patch. This will fix this issue with the chapters being out of order. I did notice that if you click cancel when in the import chapter screen that it goes to a none existent page.
              No other issues.
              Test passed.

              stronk7 Eloy Lafuente (stronk7) added a comment -

              Big thanks for the effort. This is now part of Moodle upstream. Let's wait for regressions, yay! LOL

              Ciao


                People

                • Votes:
                  1 Vote for this issue
                  Watchers:
                  1 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    25/Jun/12