Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-33292

Add ability to drag/drop the chooser dialogues (module chooser)

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.3
    • Fix Version/s: 2.3
    • Component/s: JavaScript
    • Labels:
      None

      Description

      One of the requested features of the module chooser has been to make it possible to move the chooser around the screen.

      It should be possible to do this in either:

      • plug in the modchooser.js code; or
      • plug in the chooserdialogue.js code for all chooser dialogues; or
      • plug in the notification.js code to allow for any Dialogue or anything it extends (including chooserdialogue and thus modchooser).

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              dobedobedoh Andrew Nicols added a comment -

              I've done this as two commits. One adds the capability to the Dialogue and attaches the handler to the dialogue header.
              The other consumes that for all chooser dialogues.

              This isn't a MUST for 2.3 and can wait for 2.4 but I wanted to do this before it slips down my priority listings.

              kabalin Ruslan Kabalin added a comment -

              Looks nice to me, I have also verified this feature as used it for MDL-33191 testing.

              dobedobedoh Andrew Nicols added a comment -

              Turns out that MDL-33192 didn't quite address all of the issues.

              dobedobedoh Andrew Nicols added a comment -

              Just added the move cursor to the title bar to let people know it can be moved

              kabalin Ruslan Kabalin added a comment -

              Looks good, +1 for integration.

              poltawski Dan Poltawski added a comment -

              Integrated, thanks

              poltawski Dan Poltawski added a comment -

              Tested in multiple browsers, including Safari - and surprisingly it works!

              poltawski Dan Poltawski added a comment -

              (including mobilesafari, you can drag with finger)

              stronk7 Eloy Lafuente (stronk7) added a comment -

              Big thanks for the effort. This is now part of Moodle upstream. Let's wait for regressions, yay! LOL

              Ciao


                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    25/Jun/12