Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-33306

Multichoice question type: correct answer display formatted badly

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.2, 2.3.1, 2.4
    • Fix Version/s: 2.2.5, 2.3.2
    • Component/s: Questions
    • Labels:
    • Testing Instructions:

      1. Create a multichoice question, with a single right answer.
      2. Preview it, and make sure the option Right answer is set to shown.
      3. Click Submit all and finish. Verify that the right answer is shown like "The correct answer is: No." all one one line, not split over several lines.

      4. Rinse and repeat with a question that allows multiple right answers.

      Show
      1. Create a multichoice question, with a single right answer. 2. Preview it, and make sure the option Right answer is set to shown. 3. Click Submit all and finish. Verify that the right answer is shown like "The correct answer is: No." all one one line, not split over several lines. 4. Rinse and repeat with a question that allows multiple right answers.
    • Affected Branches:
      MOODLE_22_STABLE, MOODLE_23_STABLE, MOODLE_24_STABLE
    • Fixed Branches:
      MOODLE_22_STABLE, MOODLE_23_STABLE
    • Pull from Repository:
    • Pull Master Branch:

      Description

      The problem is TinyMCE wrapping each subquestion in <p> tags. We need to use CSS to supress that, like with multichoice specific feedback.

        Gliffy Diagrams

          Issue Links

            Activity

            amanda.doughty Amanda Doughty added a comment -

            This is the same issue as MDL-28979, so I cloned it, but I cannot edit the fix version out :/

            stronk7 Eloy Lafuente (stronk7) added a comment -

            The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

            TIA and ciao

            stronk7 Eloy Lafuente (stronk7) added a comment -

            Integrated (22, 23 & master), thanks!

            dmonllao David Monllaó added a comment -

            Tested both in master and 22, it passes. The .r1.highlight overwrites of the last edited question also works as expected

            stronk7 Eloy Lafuente (stronk7) added a comment -

            Many thanks for the hard work.

            These changes have been spread upstream and are already available in the git and cvs repositories.

            Ciao


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  10/Sep/12