Details

    • Type: Sub-task
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.3
    • Fix Version/s: 2.3
    • Component/s: Themes
    • Labels:
    • Testing Instructions:
      1. Add a chat resource
      2. Switch to theme MyMobile
      3. Open the chat window as admin
      4. Login a student using another session (other browser)
      5. Open the chat window
      6. Chat in both windows and make sure the messages are sent/received
      7. Login as a student using different mobile devices
      8. Open the chat and make sure you can send/receive messages
      Show
      Add a chat resource Switch to theme MyMobile Open the chat window as admin Login a student using another session (other browser) Open the chat window Chat in both windows and make sure the messages are sent/received Login as a student using different mobile devices Open the chat and make sure you can send/receive messages
    • Affected Branches:
      MOODLE_23_STABLE
    • Fixed Branches:
      MOODLE_23_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      MDL-33317-master

      Description

      This test requires the MyMobile theme to be selected as the theme for mobile devices in Settings > Site administration > Appearance > Themes > Theme settings.

      A mobile device (smartphone with a full browser) should also be used for running the test.

      Ideally all functionality of Moodle should work, but for this test just try these basic operations:

      1. Login in as a student and check the My home page displays correctly.
      2. Go to a course and post in a forum.
      3. View a page resource.
      4. Participate in a chat.
      5. Attempt a quiz.
      6. View the list of course participants.

      Results

      all tests pass ok except 4.

      unable to participate in chat ie. post, using standard interface. ok with accessible interface. unsure if mymobile theme is intended support standard chat interface?

      using iphone running ios 5.1.1

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              chadsta Chad Outten added a comment -

              2.3 QA Test Cycle 1

              chadsta Chad Outten added a comment -

              screenshot of standard chat interface on mobile using mymobile theme

              lazydaisy Mary Evans added a comment -

              @John

              I am assigning this to you as maintainer for the MyMobile theme. This needs fixing for Moodle 2.3

              lazydaisy Mary Evans added a comment -

              Hi Chad, thanks for adding this, I have just assigned it to John Stabinger who maintains this theme.

              Just one thing, the screenshot.jpg just looks like a holiday snapshot and nothing to do with this issue. Can you check it out as I am wondering if you posted the wrong image?

              Thanks
              Mary

              epsd John Stabinger added a comment -

              This is how the theme has always been. There is a conflict between the JS and the touch optimization and the yui chat js and frames. I've spent a ton of time tinkering with it over the last few months, but to no avail. The accessible interface works as noted.

              If anyone has ideas I'm open to them, but I'm not confident it can be corrected. Is there a way to stop the theme from loading its css and js for certain page types? Maybe a renderer that stops the output of theme css/js on the chat page.

              lazydaisy Mary Evans added a comment -

              If this cannot be fixed John, shall I assign it to Moodle.com?

              What if Moodle.com developers came up with a minified version of CHAT for Mobiles...that would be super.

              Cheers
              Mary

              chadsta Chad Outten added a comment -

              @Mary: correct - first image wasn't attached properly and i don't have permissions to delete.
              @John: appreciate the comment. btw, great mobile/tablet themes - keep up the good job!

              Cheers, Chad

              salvetore Michael de Raadt added a comment -

              I've removed the faulty image. We can't have people thinking we're going on holidays here.

              fred Frédéric Massart added a comment -

              I have found that using jQuery.noConflict() resolved the issue. But there is probably a bit of work to do in the theme itself to make it easier to set the focus on the input field.

              poltawski Dan Poltawski added a comment -

              Adding John Stabinger here, but looks good to me.

              nebgor Aparup Banerjee added a comment -

              this looks fine and works well for me on the iphone (ios 5.1.1)

              abgreeve Adrian Greeve added a comment -

              Tested this in a couple of browsers and my iPhone 3GS. The focus in the text area on my iPhone was a bit of an issue, but when it finally got focus I could send and receive messages quite well.
              Test passed

              stronk7 Eloy Lafuente (stronk7) added a comment -

              Big thanks for the effort. This is now part of Moodle upstream. Let's wait for regressions, yay! LOL

              Ciao


                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  3 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    25/Jun/12