Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.3
    • Fix Version/s: 2.3
    • Component/s: Assignment
    • Labels:
    • Testing Instructions:
      1. Create a new instance of mod_assign in a unit with enrolled users.
      2. Go to the new instance and click on "View/grade all submissions"
      3. Confirm the filter options table is now below the submissions table
      4. Confirm the actions form is now a single url select above the header
      5. Confirm the batch operations form is now collapsed to a single line beneath the submissions table
      Show
      Create a new instance of mod_assign in a unit with enrolled users. Go to the new instance and click on "View/grade all submissions" Confirm the filter options table is now below the submissions table Confirm the actions form is now a single url select above the header Confirm the batch operations form is now collapsed to a single line beneath the submissions table
    • Affected Branches:
      MOODLE_23_STABLE
    • Fixed Branches:
      MOODLE_23_STABLE
    • Pull Master Branch:

      Description

      1. The old assignments had only the sorting of entries by name (firstname/surname) above the entries listing. However the new one does not have this feature anymore

      2. It is also missing the link at top of "View assignment grades and feedback" or "No attempts have been made on this assignment" which I guess was left in the "2.2" assignment to have it easy to get into that screen since it is so heavily used without scrolling.

      3. Equally the link above listing of "Download all submissions" which is there on 2.2 assignment is gone in new one.

      4. In addition it also has 2 "options" tables above the listing

      Should these not be below the lists as with the old version, especially for usability reasons of keeping the content at top of page otherwise a user has to scroll for more than 5 people (on 1024 size)

        Gliffy Diagrams

        1. now-view.png
          33 kB
        2. old-view.png
          36 kB

          Issue Links

            Activity

            ghenrick gavin henrick added a comment -

            Old view

            ghenrick gavin henrick added a comment -

            The new view with feature missing and config options above listing..

            dougiamas Martin Dougiamas added a comment -

            +1 for these! The new assignment must have all the same features as the old one. And agreed on avoiding scrolling.

            salvetore Michael de Raadt added a comment -

            Hi, Gavin.

            Thanks for keeping an eye on the assignment development.

            By 1, I assume you mean the filter bar for name initials. That's pretty easy to add to this table.

            By 2, I assume you mean the links on the initial view page. This link has been replaced by a submission summary table, but perhaps this could appear above the description (which is potentially long).

            In relation to 3, there is a download all submissions link, but it is now in the Settings block. A redundant link could be added for consistency with the old version, but personally I think the Settings block is a better place for it.

            I agree with your suggestion in point 4. The settings should appear below the table.

            ghenrick gavin henrick added a comment - - edited

            on #2 Although the submission summary is now there, and it is good, I would agree with it being above the description table - however I think the table vs the simple link is a backwards step in usability. The simplicity of the link with all the info needed "View 1 submitted assignments" stands out more and would follow the concepts of "dont make me think". One improvement to the summary box would be making the number for the submissions to be a link "6 submissions" or a view all beside the full number of potential.

            on #3 although it is in settnigs block, more than likely that will require someone to scroll down the page before then can access it vs a 1 click link, so having the link also at the top preserves the functionality from the "2.2" assignment to minimise the impact of change, but also maintains usability.

            damyon Damyon Wiese added a comment -

            Hi Gavin,

            on #2 the reason the submission summary is not above the description is that some people use the description field to provide instructions to students - and the instructions should come before the submission information.

            on #3 Download all is in the settings block and in the drop down list in the grading actions table. This is a list and not a table because I have a heap of other features waiting to be integrated that will add more functions to this table and a long list of links takes too much space and is less usable.

            ghenrick gavin henrick added a comment - - edited

            regarding #2 then, please re-add the list to have consistency with the 2.2 assignment - I understand your reasoning for having the summary box below description, but making people scroll or look somewhere else for that link is not a good thing.

            regarding #3 totally understand, however moving those grading actions table and grade list table below the list of submissions is essential again as it was that in 2.2 and it is a usability backwards step having these above the submissions. So once they are moved, adding back the link (as per 2.2) above the submissions list is not a bad thing, keeping consistency with for all the current users of the assignment.

            I believe it is very important to try and follow the usability concepts like:

            • people are habitual ( so making a change like adding those boxes above the list must have a usability bonus for the majority before doing it.)
            • don't waste users time (by getting in the way of their most common tasks by adding clicks or scrolling)
            • don't make them think (like moving from a link to having it in a dropdown which is hiding the option so they need to figure out where it is)

            I think moreso with the assignment re-work than other aspects, the chance for impacting users confidence is high, so maintaining the same type of usability is key.

            damyon Damyon Wiese added a comment -

            Regarding #1 - the clickable list of user initials works exactly the same is it does for 2.2 - the list only shows if the table is paginated.

            Regarding #4 - I have made the change to reduce the size of the actions forms and moved the filter options below the table - but I don't think this is clear cut - there are 2 conflicting usability issues here: one is the desire to reduce scrolling, the other is the desire for consistency with the rest of Moodle (I could not find any other page in where the filter/pagination options are presented below the list). My preference is to have the new reduced size filter options table appear above the list of submissions.

            damyon Damyon Wiese added a comment -

            Regarding #2 - I have not made this change as I think it should be split into a separate bug and voted on.

            ghenrick gavin henrick added a comment -

            Surely a vote is not needed to put in the existing feature. A vote would be more appropriate to remove?

            Sorry for my approach but I thought the goal was to replicate the features of original assignments first, before going into perceived improvements and changes?

            So therefore removing a feature is out of scope?

            damyon Damyon Wiese added a comment -

            Hi Gavin, I just don't think of it as a missing feature - the functionality is all there it's just that the link is now a button and the grading summary table does a much better job of conveying the grading status of the assignment than a one line summary.

            stuartlamour Stuart Lamour added a comment -

            +1 for gavin on this, content first - most frequent tasks for most users displayed prominently.
            Maybe try testing these changes with users (i.e. teachers) - i'm sure this will highlight any issues.

            ghenrick gavin henrick added a comment -

            just checking on update for moving of the options etc below the content, will this be in 2.3?

            fred Frédéric Massart added a comment -

            Hi Damyon, before reviewing your code, could you rebase your branch?
            There are conflicts that you might want to have a look at, especially the ones caused by MDL-33572.

            damyon Damyon Wiese added a comment -

            OK - I won't get to this today though it will have to be tomorrow morning.

            Regards, Damyon

            damyon Damyon Wiese added a comment -

            Resolved conflicts and made the patch smaller by removing changes to dirty form handling.

            damyon Damyon Wiese added a comment -

            This has been merged with the integration branch and is ready to look at again.

            fred Frédéric Massart added a comment -

            Hi Damyon,

            your patch looks great! I was wondering while you're in this issue, what do you think about adding the 'initial bar menu' that was present in Assignment 2.2? (see description #1)

            And about description #2, my knowledge of Moodle is not good enough to be sure what we are talking about there, could you please check if this has been integrated?

            If you update your branch I'll have another quick review, if not feel free to send to integration whenever you're ready.

            Cheers

            damyon Damyon Wiese added a comment -

            Thanks Frederick,

            I'll send this for integration as there are no more changes required for the Initials bar. The "Initials bar" is working, but you need to have more than one page of students before it will appear (this is the same as the old assignment).

            Regards, Damyon

            ghenrick gavin henrick added a comment -

            Hi Damyon - that is incorrect about the initials bar please look at old-view.png

            As shown in the image above (and go ahead and check normal 2.2 Moodle, the "initials" bar appears always and is not dependent on having more than 1 page of entries.

            As per your comment about a link being a button.
            I checked the Developer guidelines, they say that the current Moodle standard for use of Link or Button is ->
            "Actions which can modify the state of Moodle (data files, database, session information) should be performed through buttons.

            Buttons should never be used for navigation. Instead, use links. " So as this links to the other page can we change it back to the link please?

            And assuming it does can you put back the feature aspect of it showing the number and whether there are assignments submitted in it as detailed above. otherwise this is lost functionality.

            damyon Damyon Wiese added a comment -

            Hi Gavin,

            Sorry - I didn't realise that behaviour of the old assignment I was using the default behaviour of the table class in Moodle.

            I'll create 2 separate tickets for the change of the button to a link and the reinstating of always displaying the initials bar.

            poltawski Dan Poltawski added a comment -

            Integrated, thanks

            poltawski Dan Poltawski added a comment -

            Tested during integration. I hope there is lots more of assignment testing happening as this is a big change for such a late stage!

            dougiamas Martin Dougiamas added a comment -

            My -1 for changing the initials bar behaviour that 2.3 has now. I think it's a nice small improvement to hide the "initials" selection bar when the full class list is short and right in front of you anyway. MDL-33772

            stronk7 Eloy Lafuente (stronk7) added a comment -

            And this has been spread to every git and cvs repository out there, just in time to roll Moodle 2.3beta!

            Thanks! Closing, ciao


              People

              • Votes:
                1 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  25/Jun/12