Moodle
  1. Moodle
  2. MDL-33414

Cannot view entirety of Online Text in Assignment 2.3

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.3
    • Fix Version/s: 2.3
    • Component/s: Assignment
    • Labels:
    • Testing Instructions:
      1. Create an assignment (new one) with the onlinetext submissions enabled.
      2. Login as a student and make a 100 word submission to the assignment.
      3. Login as a teacher and click on View/grade all submissions
      4. Verify that there is a magnifying glass icon above the submission summary in the grading table
      5. Click on the magnifying glass to view the full submission
      Show
      Create an assignment (new one) with the onlinetext submissions enabled. Login as a student and make a 100 word submission to the assignment. Login as a teacher and click on View/grade all submissions Verify that there is a magnifying glass icon above the submission summary in the grading table Click on the magnifying glass to view the full submission
    • Workaround:

      Download all submissions as a zip file. Read individual HTML files of student submissions.

      Show
      Download all submissions as a zip file. Read individual HTML files of student submissions.
    • Affected Branches:
      MOODLE_23_STABLE
    • Fixed Branches:
      MOODLE_23_STABLE
    • Pull Master Branch:
    • Rank:
      41290

      Description

      Using the new 2.3 Assignment, there is no way to view the entirety of an online text submission without first downloading all submissions to a zip file.
      Steps to reproduce:
      1. Create a new 2.3 Assignment, setting it to allow Online Text.
      2. As a student, submit an entry of more than 20 or 25 words to this assignment. I used 5 paragraphs from Bacon Ipsum.
      3. As an instructor, navigate to the assignment and go into the grading view for the above submission.

      Expected: Should be able to see the entire submission, either in the grading view, or in an additional pop-up window.
      Actual Result: There is no method for viewing the entire submission in Moodle.

        Issue Links

          Activity

          Damyon Wiese added a comment -

          Thanks Chad, I can reproduce this on the QA site. There should be a link to view the full submission but it's not showing for some reason. I'll take a look.

          Sam Hemelryk added a comment -

          Hi Damyon,

          I've looked at this change and I can certainly see how it works and how it solves the problem.
          But to be truthful I'm not a big fan of using references like this. I would prefer to see something like a dedicated callback [assign_plugin::show_full_view_link] and behavior altered based upon that rather than tagging a reference variable into view_summary to shortcut a return and because it is convenient.

          However this REALLY needs to land before 2.3 is released and thats getting ever closer so perhaps this is a good solution for now and we can look at that in the future.

          So feel free to put this up for integration now

          Cheers
          Sam

          Damyon Wiese added a comment -

          Hi Sam,

          It does it like this more for performance reasons rather than convenience, otherwise the plugin would have to lookup it's plugin specific data twice - e.g:
          [get onlinetext submission from submission id]
          [check length to determine if it needs shortening]
          [throw away the online text submission and just return true/false]
          [get onlinetext submission from submission id]
          [shorten it if required]
          [return the shortened onlinetext submission]

          I'll put this up for integration not but I'm happy for further discussion on this.

          Dan Poltawski added a comment -

          Like Sam, i'm not a fan of this but now is the time for pragmatism

          Thanks Damyon, i've integrated this now

          Dan Poltawski added a comment -

          Manually passing the test as is to be covered by linked QA test.

          Dan Poltawski added a comment -

          (testing it myself manually just in case something has been missed from the QA test)

          Dan Poltawski added a comment -

          (tested, thanks)

          Chad Bergeron added a comment -

          Thanks, this works in my instance as well. Now to go file a feature request that it open in a pop-up window....

          Dan Poltawski added a comment -

          Congratulations!

          Your work has made into the latest Moodle release!

          You are only authorised to celebrate after testing 15 Moodle 2.3 QA tests, thanks!


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: