Details

    • Type: Sub-task
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 2.3
    • Fix Version/s: 2.3
    • Component/s: Files API, Repositories
    • Labels:
    • Testing Instructions:

      1. Login as admin or teacher and make sure that you have at least one non-empty course
      2. Open any page with filemanager form element or tinymce editor
      3. Try to insert file as a shortcut/alias from Server files repository
      4. Make sure it is inserted as reference
      5. Update the source file, make sure the reference is updated
      6. Try different ways of deleting the source file: delete file in filemanager, delete resource/activity, delete form post, delete course.
      7. Make sure the reference is transformed into true copy

      Show
      1. Login as admin or teacher and make sure that you have at least one non-empty course 2. Open any page with filemanager form element or tinymce editor 3. Try to insert file as a shortcut/alias from Server files repository 4. Make sure it is inserted as reference 5. Update the source file, make sure the reference is updated 6. Try different ways of deleting the source file: delete file in filemanager, delete resource/activity, delete form post, delete course. 7. Make sure the reference is transformed into true copy
    • Affected Branches:
      MOODLE_23_STABLE
    • Fixed Branches:
      MOODLE_23_STABLE
    • Pull Master Branch:
      wip-MDL-33420-master

      Description

      Allow to create alias/shortcut to any file in Server files (enabled by setting for 'Server files' repository).
      Use the same function to build names for list of shortcuts and origins.

      Examples:
      Server files: CATEGORY/COURSE/MODULE/area,.../FILEPATH/FILENAME
      Server files: CATEGORY/COURSE/Course legacy files/FILEPATH/FILENAME
      Server files: Front page/MODULE/area,.../FILEPATH/FILENAME
      Server files: Admin User/Profile/FILEPATH/FILENAME
      Admin User Private files: /FILEPATH/FILENAME

      (basically only different for user private files)

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              marina Marina Glancy added a comment -

              Please integrate after (or together with) MDL-33550

              poltawski Dan Poltawski added a comment -

              Picking this up because I also have the blocked issue.

              poltawski Dan Poltawski added a comment -

              Reopening this as the blocking issue is reopneed.

              cibot CiBoT added a comment -

              Moving this reopened issue out from current integration. Please, re-submit it for integration once ready.

              poltawski Dan Poltawski added a comment -

              I've integrated this now

              fred Frédéric Massart added a comment -

              Works great! Good job guys!

              stronk7 Eloy Lafuente (stronk7) added a comment -

              Big thanks for the effort. This is now part of Moodle upstream. Let's wait for regressions, yay! LOL

              Ciao


                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    25/Jun/12