Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-31167 PHP strict META
  3. MDL-33479

Strict standards validation in flexible_table defined in lib/tablelib.php

    Details

    • Type: Sub-task
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.3
    • Fix Version/s: 2.3
    • Component/s: Other
    • Labels:
      None

      Description

      This notice was really annoying:
      Strict Standards: Redefining already defined constructor for class flexible_table in .../moodle/lib/tablelib.php on line 139

      here is the fix:

      https://github.com/marinaglancy/moodle/compare/master...wip-tablelib

        Gliffy Diagrams

          Attachments

            Activity

            poltawski Dan Poltawski added a comment -

            The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

            TIA and ciao

            poltawski Dan Poltawski added a comment -

            Me and marina chatted about this, because I don't actually get the strict warning (5.3.10 but marina 5.3.2 does) with the following code:

            <?php
             
            require_once('config.php');
            require_once($CFG->libdir.'/tablelib.php');
             
            $test = new flexible_table('test-table');
             
            echo 'yipee, no errors';
            print_object($CFG->debug);
            print_object($CFG->debugdisplay);

            poltawski Dan Poltawski added a comment -

            Integrated, thanks

            poltawski Dan Poltawski added a comment -

            Tested for regressions and looks good.

            stronk7 Eloy Lafuente (stronk7) added a comment -

            We could celebrate it today... but better if we perform a bigger party after releasing Moodle 2.3.

            Print this message and come to Perth that day, it's valid for one beer, wine, coke or... water, as you wish.

            Many thanks for your collaboration!

            Ciao


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  25/Jun/12