Moodle
  1. Moodle
  2. MDL-33499

Assign mod do not inform grader of FINAL gradebook grade, only the raw assignment grade.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.3, 2.4
    • Fix Version/s: 2.3.1
    • Component/s: Assignment
    • Labels:
      None
    • Testing Instructions:
      1. Create and instance of the mod_assign in a course
      2. Click on View/grade all submissions to view the grading page
      3. Grade one of the submissions
      4. Confirm on the grading page you see an additional row for the "Current grade in gradebook" which should be "-" for a new grade
      5. Save the grade and then grade that student again. The "Current grade in gradebook" should be updated to show the new grade
      6. Click on the "Current grade in gradebook" value which should be a link to the gradebook for this course.
      7. Turn editing on and edit one of the grades for the assignment
      8. Go back to the assignment in the course and edit the grade for that user
      9. Confirm you see the updated gradebook grade in that "Current grade in gradebook" row
      Show
      Create and instance of the mod_assign in a course Click on View/grade all submissions to view the grading page Grade one of the submissions Confirm on the grading page you see an additional row for the "Current grade in gradebook" which should be "-" for a new grade Save the grade and then grade that student again. The "Current grade in gradebook" should be updated to show the new grade Click on the "Current grade in gradebook" value which should be a link to the gradebook for this course. Turn editing on and edit one of the grades for the assignment Go back to the assignment in the course and edit the grade for that user Confirm you see the updated gradebook grade in that "Current grade in gradebook" row
    • Affected Branches:
      MOODLE_23_STABLE, MOODLE_24_STABLE
    • Fixed Branches:
      MOODLE_23_STABLE
    • Pull Master Branch:

      Description

      The new Assign module interface presents to graders just the raw grade in the Assign mod. The teacher has no visual feedback of any CALCULATION performed with that grade in the gradebook (and the students, by the way, only see teh final calculated grade, not the rawgrade).

      In our experience in ULPGC this can be very misleading for the grader, even more now since raw grades in Assign can be decimals. The teachers can confuse the raw grade and final grade, and introduce as rawgrade in Assign the expected value after calculation, with the effect of calculating twice and trashing the grade value.

      We think this is a regression, it is much better the behavior of Assignment2.2, where the grading form explicitly includes two rows:

      • one for rawgrade (been changed in this grading form)
      • one for Final calculated grade as currently in the gradebook ( "-" or a number)

        Gliffy Diagrams

          Issue Links

            Activity

            Sam Hemelryk added a comment -

            Hi Damyon,

            The changes for the most part look good and make sense.
            There were two things I did note, neither major:

            1. has_all_capabilities could be used instead of two cap calls (totally up to you)
            2. PARAM_INT shouldn't that be PARAM_FLOAT?

            Feel free to put this up for integration when you are ready.

            Cheers
            Sam

            Damyon Wiese added a comment -

            Thanks Sam, Sending for integration. I updated the patch to use has_all_capabilities and removed the set type completely as the field is a static form element and will not submit anything or do any processing of the element.

            Damyon Wiese added a comment -

            (Last update did not contain the lastest changes - I just re-pushed this branch)

            Eloy Lafuente (stronk7) added a comment -

            Integrated, thanks! (23_STABLE and master)

            Andrew Davis added a comment -

            Works as described. Passing.

            Sam Hemelryk added a comment -

            Congratulations your code is upstream - gold star for you!

            This issue + 79 others made it in in time for the minor releases.
            Thank you everyone involved for your exuberant efforts.


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: