Moodle
  1. Moodle
  2. MDL-33523

Some warnings and basic problems restoring one IMSCC file generated by Moodle export

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 2.2.3, 2.3
    • Fix Version/s: 2.2.4
    • Component/s: Backup: IMS-CC
    • Labels:
    • Testing Instructions:

      Using the backup of a course attached to the issue MDL-33080 perform a restore and then export it in common cartridge format. Note for 22_STABLE this requires $CFG->enablebackupconverters = true; @ config.php

      Try to restore that common cartridge.

      None of the problems excluding item B will be present.

      Show
      Using the backup of a course attached to the issue MDL-33080 perform a restore and then export it in common cartridge format. Note for 22_STABLE this requires $CFG->enablebackupconverters = true; @ config.php Try to restore that common cartridge. None of the problems excluding item B will be present.
    • Affected Branches:
      MOODLE_22_STABLE, MOODLE_23_STABLE
    • Fixed Branches:
      MOODLE_22_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      MDL-33523_master

      Description

      This was detected while testing MDL-33080.

      To reproduce:

      1) Restore the attached course backup @ MDL-33080 into new course.
      2) It contains one label, one page resource and one IMS-CP activity (playing one SCORM package).
      3) Backup it as IMS-CC
      4) Restore the generated .imscc package

      Annoyances:

      A - In the process, this warning is shown:

      Warning: copy(pix/f/folder.gif) [function.copy]: failed to open stream: No such file or directory in backup/cc/entities11.class.php on line 72

      (not sure why any icon is copied at all. No especial "decoration" should be shown)

      B - The IMS-CP activity/package is completely missing.

      C - There are 3 "Untitled" in the resulting course. And 4 missing icons (the "folder" ones, I bet).

      Ciao

        Gliffy Diagrams

          Issue Links

            Activity

            Darko Miletic added a comment -

            All of this and lots of other things are already fixed in our internal builds. However we still did not have oportunity to sit and plan the next steps in integrating further work on common cartridge.

            Eloy Lafuente (stronk7) added a comment -

            Nice to ear it's fixed in your internal builds. Shame it's not in the upstream builds.

            How can we be making the export to ims-cc option public with this and lots of other things not fixed?

            Uhm... ciao

            Martin Dougiamas added a comment -

            Darko, can you push the bug fixes to us upstream?

            Darko Miletic added a comment -

            Starting the work

            Darko Miletic added a comment -

            I will soon commit the fix and here is the explanation of the issues:

            A - The image in question is no longer in Moodle distribution so I changed to the one being present. We added a folder image for all labels because it was considered to be nicer during import.
            B - IMS package is missing because this content is not supported by export. That applies for any Moodle content not supported by export. Common cartridge can not contain other common cartridge or scorm elements.
            C - This was an inconsistency in the way labels where processed. Fixed.

            Eloy Lafuente (stronk7) added a comment -

            Integrated, thanks! (22 & master)

            Jason Fowler added a comment -

            All tests passed with flying colours

            Eloy Lafuente (stronk7) added a comment -

            And this has been incorporated to all the weekly builds and also, to Moodle 2.3 Release Candidate 1, yay!

            Many, many thanks for your hard work!

            Ciao


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: