Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-33572

Inconsistent display of "Graded" status in new assignment

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.3
    • Fix Version/s: 2.3
    • Component/s: Assignment
    • Labels:
    • Testing Instructions:
      1. Create an instance of mod_assign in a course with enrolled students
      2. Visit the grading page (View/grade all submissions) and choose "Prevent submission changes" from the edit menu for a submission
      3. Verify that the grading status for that submission does not say "Graded" in the grading table.
      4. Enable quick grading on for the grading table and verify that the grade input for that student is empty
      5. Visit the full grading page for that student and verify that the grade input for that student is empty
      6. Logout and login using the student account that was just graded and visit the assignment.
      7. Verify that the grading status shown to the student does not say "Graded"
      Show
      Create an instance of mod_assign in a course with enrolled students Visit the grading page (View/grade all submissions) and choose "Prevent submission changes" from the edit menu for a submission Verify that the grading status for that submission does not say "Graded" in the grading table. Enable quick grading on for the grading table and verify that the grade input for that student is empty Visit the full grading page for that student and verify that the grade input for that student is empty Logout and login using the student account that was just graded and visit the assignment. Verify that the grading status shown to the student does not say "Graded"
    • Affected Branches:
      MOODLE_23_STABLE
    • Fixed Branches:
      MOODLE_23_STABLE
    • Pull Master Branch:

      Description

      The new assignment sometimes displays that a submission has been graded when no grade has been assigned. This is due to some operations assigning a grade of -1 to indicate no grade (such as locking/unlocking a submission) - the code that displays whether a submission has been graded should ignore grades less than 0.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              damyon Damyon Wiese added a comment -

              Based ontop of this commit as it conflicts with it.

              samhemelryk Sam Hemelryk added a comment -

              Hi Damyon,

              Changes look spot on thanks. Putting this up for integration immediately.
              Could you please add testing instructions ASAP

              Cheers
              Sam

              poltawski Dan Poltawski added a comment -

              I've integrated this - thanks guys

              poltawski Dan Poltawski added a comment -

              Oh, just noticed a problem immediately after integration. grr.

                              $o = '<input type="text" name="quickgrade_' . $userid . '" value="' . $displaygrade . '" size="6" maxlength
                              $o .= '&nbsp;/&nbsp;' . format_float($this->get_instance()->grade,2);

              poltawski Dan Poltawski added a comment -
              damyon Damyon Wiese added a comment -

              Hi Dan,

              I tested the fix is correct and it looks good to me.

              Sorry about the bug.

              Regards, Damyon

              fred Frédéric Massart added a comment -

              Successfully tested on master. Cheers!

              stronk7 Eloy Lafuente (stronk7) added a comment -

              Big thanks for the effort. This is now part of Moodle upstream. Let's wait for regressions, yay! LOL

              Ciao


                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  0 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    25/Jun/12