Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-33598

Student cannot set messaging preferences for assignment

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 2.3
    • Fix Version/s: 2.3
    • Component/s: Assignment
    • Labels:
    • Testing Instructions:
      1. Log in as a student
      2. Navigate to Settings > My profile settings > Messages
      3. Make sure you can change the settings for 'Assignment student notifications'
    • Workaround:

      mod/assign/db/messaging.php, lines 27-30

          // Ordinary assignment submissions
          'assign_student_notification' => array (
              // 'capability' => 'mod/assign:submit'
          ),

      Show
      mod/assign/db/messaging.php, lines 27-30 // Ordinary assignment submissions 'assign_student_notification' => array ( // 'capability' => 'mod/assign:submit' ),
    • Affected Branches:
      MOODLE_23_STABLE
    • Fixed Branches:
      MOODLE_23_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      MDL-33598-master-integration

      Description

      It is not possible for a student to change their messaging preferences for the new assignment module.

      This is because there is a capability associated with the messaging provider assign_student_notification, which applies at the module level but not at the site level, where messaging settings are set.

      The quick fix is to remove this capability from the provider. This is not ideal, but it is what happens in the 2.2 assignment, forum and lesson. I am also going to create another issue to review the implications of messaging settings at different context levels.

      Replication steps:

      1. Log in as a student
      2. Navigate to Settings > My profile settings > Messages

      Expected result: You should be able to control the provider labelled "Assignment student notifications".

      Actual result: There is no provider listed as "Assignment student notifications"

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              salvetore Michael de Raadt added a comment -

              It looks like the convention (although not written down anywhere) is to break the array over multiple lines, possible so it looks like content could be added. So even though the array will have no content, for consistency, you might want to maintain the line break. This is purely a style issue.

              fred Frédéric Massart added a comment -

              Patch updated, submit for integration.

              poltawski Dan Poltawski added a comment -

              Pinging Damyon about this as component maintainer.

              Damyon, can you give a +1?

              damyon Damyon Wiese added a comment -

              The patch looks fine to me and I tested this and could change my "Assignment student notifications" as a student.

              Thanks Frédéric

              Regards, Damyon

              poltawski Dan Poltawski added a comment -

              Integrated, thanks

              poltawski Dan Poltawski added a comment -

              Passed.

              (didn't check delivery, assume that is done in QA tests linked)

              stronk7 Eloy Lafuente (stronk7) added a comment -

              Big thanks for the effort. This is now part of Moodle upstream. Let's wait for regressions, yay! LOL

              Ciao


                People

                • Votes:
                  1 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    25/Jun/12