Moodle
  1. Moodle
  2. MDL-33611

Better wording for quiz modulename_help

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.3
    • Fix Version/s: 2.3
    • Component/s: Quiz
    • Labels:
    • Testing Instructions:

      1. Click the 'Add an activity or resource' link.
      2. Click on Quiz.
      3. Marvel at how beautifully concise and informative the help string now is.

      Show
      1. Click the 'Add an activity or resource' link. 2. Click on Quiz. 3. Marvel at how beautifully concise and informative the help string now is.
    • Affected Branches:
      MOODLE_23_STABLE
    • Fixed Branches:
      MOODLE_23_STABLE
    • Pull from Repository:
    • Pull Master Branch:
    • Rank:
      41552

      Description

      I feel that the current text is longer than necessary, so people won't read it. My attempt to do better is below. This actually fits in the activity chooser at the default size. Is this an improvement? Can anyone do even better?

      Quizzes are automatically graded activities built from variety of question types, including multiple choice, matching, short-answer and numerical. There is a choice for how students complete the quiz, including

      • Deferred feedback - a classic exam where students record answers for all the questions which are graded at the end, or
      • Interactive - students submit questions as they go along and get feedback. If they are wrong, they can immediately try again for less marks.

      There are many options for controlling when students can attempt the quiz, how much time they are allowed, and so on. The teacher can also control when and if students can see the feedback, correct answers, numerical marks, etc.

      Quizzes may be used

      • As formal parts of the course assessment
      • As mini tests for reading assignments or at the end of a topic
      • As exam practice using questions from previous years' exams
      • To provide feedback about performance
      • For self-assessment

        Activity

        Tim Hunt added a comment -

        I am also submitting this new string as a patch, since I made it to see the new string in context. I am happy to amend it if people can suggest improvements.

        Helen Foster added a comment -

        Tim, thanks for your suggested rewording of quiz modulename_help. I've added Michelle as a watcher as she has kindly agreed to review all the activity and resource help texts.

        Tim Hunt added a comment -

        OK, I will wait until I have heard from Michelle before I submit this for integration. Thanks.

        Helen Foster added a comment -

        Here are Michelle's suggested improvements to the quiz help (copied from the Word doc attached to MDL-32925):

        The quiz activity module enables a teacher to design and set quizzes consisting of a variety of question types, including multiple choice, true-false, matching, short-answer, and calculated. Quiz questions may be created in Moodle or imported from publisher test banks or text files you create.

        A teacher can allow the quiz to be attempted multiple times with the questions shuffled or randomly selected from the question bank. A time limit for the quiz may be set if desired.

        Each attempt is automatically marked, with the exception of essay questions, with the grade recorded in the gradebook. The teacher can choose whether to give feedback and/or show correct answers to the student during the attempt, immediately after the attempt or after the quiz is closed.

        A teacher can choose from a variety of question behaviours, including adaptive mode (providing hints before allowing the student to try again) and immediate feedback with certainty-based marking (where the student must indicate how sure they are of the answer).

        Quizzes may be used

        • As unit or course exams
        • As mini tests for reading assignments or at the end of a topic
        • As exam practice using questions from previous years’ exams
        • To deliver immediate feedback for printed workbook activities; rather than students answering questions on a paper and waiting for an instructor to score them, the workbook questions are set up in a quiz and students answer questions there instead.
        • To provide feedback about performance
        • For self-assessment
        • With the question creator role, students can be tasked with writing quiz questions and adding them directly to the question bank for use by the teacher on practice or graded quizzes (http://docs.moodle.org/22/en/Question_creator_role)
        Helen Foster added a comment -

        Obviously Michelle's suggested improvements make the help text longer, rather than shorter. My original brief was to come up with text of length approx 170 words. (The current quiz help text happens to be exactly 170 words.)

        I think Michelle's suggested improvements, with her teacher / trainer perspective, are generally really good. However, as the quiz help is intended to be an introduction, I think we should not mention the question creator role, and leave it for the docs. Re. 'Quiz questions may be created in Moodle...' we generally try to avoid using the word 'Moodle' in lang strings, as not everyone uses the name 'Moodle.

        I'm going to try and come up with a shortened version of the current quiz text using stuff from Tim's and Michelle's suggested texts...

        Helen Foster added a comment -

        My suggested wording (reduced to 127 words and retaining elements of consistency with other module help texts) is as follows:

        The quiz activity module enables a teacher to create quizzes consisting of a variety of question types, including multiple choice, matching, short-answer and numerical.

        A teacher can allow the quiz to be attempted multiple times with the questions shuffled or randomly selected from the question bank. A time limit for the quiz may be set.

        Each attempt is automatically marked, with the exception of essay questions, and the grade is recorded in the gradebook.

        The teacher can choose when and if hints, feedback and correct answers are shown to students.

        Quizzes may be used

        • As unit or course exams
        • As mini tests for reading assignments or at the end of a topic
        • As exam practice using questions from previous years' exams
        • To deliver immediate feedback about performance
        • For self-assessment
        Mary Cooch added a comment -

        I like it! Gives enough detail without going overboard!

        Tim Hunt added a comment -

        Yay! consensus. I can even save 3 more works by taking out the 'for the quiz' in 'A time limit for the quiz may be set.' It seems redundant to me.

        Tim Hunt added a comment -

        Thanks all for your help. Submitting for integration now.

        Dan Poltawski added a comment -

        I've integrated this now, thanks

        Dan Poltawski added a comment -

        Oh hold on, there seems to be confusion about what text we are using here..

        Dan Poltawski added a comment -

        It looks like we've got Michelles text here, but not Helens shortened one?

        Tim Hunt added a comment -

        Grrr!

        Tim Hunt added a comment -

        Hmm. Re-working this is causing me to re-read the text, and I want to make some more changes. For example, "The quiz activity module ..." Surely it is better without the word module.

        Also, the pedant in me thinks that quizzes are comprise questions, which may be of various types. So, I end up with

        The quiz activity enables a teacher to create quizzes comprising questions of various types, including multiple choice, ...

        Regarding the last bullet, in Moodle, what is a 'Unit'? I think we just need to delete that.

        I was taught that when the items of a bullet list continue the previous sentence, then they should not start with a capital letter, and there should also be punctuation at the end of the items, but I will leave them so they are consistent with the other activities.

        Tim Hunt added a comment -

        OK, new commit https://github.com/moodle/moodle/commit/3f0e034d75494b4b97469b8ab027f146b2a7be4f added to the MDL-33611 branch (since it turned out that you had pushed the previous commit to integration already, Dan.)

        Dan Poltawski added a comment -

        Integrated this update now, thanks

        Dan Poltawski added a comment -

        Some words about quizzes are now present on the help

        Eloy Lafuente (stronk7) added a comment -

        Big thanks for the effort. This is now part of Moodle upstream. Let's wait for regressions, yay! LOL

        Ciao


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: